"PreArm: Logging Failed" w/ File&MavLink

For some reason I am getting a prearm check failure when enabling mavlink logging. The check continues to fail even though I start receiving mavlink log messages.

Perhaps I am missing something here but how else would I be able to use QGroundControl if I don’t have LOG_BACKEND_TYPE set to 3(File&MavLink)?

ArduCopter v3.5.5
Pixhawk 2.1
HKPilot (SIK) Telemetry
QGroundControl v3.3.0 (Linux)

“mavlink logging” is different to mavlink telemetry.

“mavlink logging” transfers dataflash log files over mavlink telemetry
while the vehicle is flying (give or take). You need a high-rate
telemetry link to do this - so it is usually only used on-board the
vehicle with a companion computer.

So, basically, just use the file backend unless you have a companion
computer you want to store df logs on :slight_smile:

Ah. What exactly would I need to enable to have the information available to QGroundControl then? It doesn’t display any useful data without mavlink logging enabled.

Are you saying you don’t get telemetry, or that you aren’t getting
dataflash logs?

I’m able to connect to the pixhawk using the telemetry module but QGroundControl wont show GPs location, gps locks, voltage, current, etc… without navlink logging enabled.

Well this is strange. It just started working out of nowhere. /shrugs

I have a similar case but I am using a companion computer- a jetson tx2, in my case. Hence I suppose I need Log_Backend _Type set to 2 or 3. Now how do I log to my CC so that I clear this pre-arm fail ?

also while I run rosservice call /mavros/log_transfer/log_request_data destination="…"
It requests me to enter further args like id , offset and count . what are these?

where can I find details about each service and each topics that mavros can provide me with?