Pre-arm RC throttle not neutral

Hi all,

I’m trying to arm my copter by pressing a button (without touching the sticks). I get the following error:

PreArm: Throttle (RC3) is not neutral

With a previous firmware version (3.6) this was not an issue but with versions 4+ it is.
The values for RC_MIN and RC_TRIM are the same as before: 1051.

If I push throttle and yaw down, then I can arm but I would rather not arm with the throttle set to min; as I don’t want to immediately engage in take-off.

My questions are:

  1. Is it no longer possible to initiate takeoff when the throttle neutral? Or is there a bug that doesn’t allow the FC to recognize neutral?
  2. If I arm with the throttle down + yaw right and then release them to neutral, will the drone take off? or is it necessary to push the throttle above neutral for take off?

Thanks in advance!

Hello @valeria

This is being caused by incorrect ARMING_RUDDER parameter list. Set it to 2 to allow arming with mid-stick position of throttle.

No, as I said, only set this ARMING_RUDDER parameter to 2 to allow it.

It depends upon your flight mode, in Stabilize it is possible if your mid-stick thrust is not so well calibrated. But it souldn’t occur in AltHold or Loiter.

Hi Bruno,

Thank you for your reply. ARMING_RUDDER is set to 2. I’ve tried disabling and re-enabling but that did not make a difference.

So maybe you have some trim/sub-trims set up in your RC device.Try to zero them and re-calibrate your Radio again in the Radio Calibration. Probably your mid-stick value is set to values higher or lower than the value defined by value in the midway of RC3_MIN and RC3_MAX +/- RC3_DZ. Check your mid-stick value by seeing the value shown at Radio Calibration Screen of Mission Planner.

Thanks, I just tried that. I still get the error.
The only thing I noticed is that in the RC the neutral value is 1500 and the max is 1950, while in the FC/Mission Planner the respective values are 1501 and 1951.

set PILOT_THR_BHV to “1”

With this you can use a center throttle and stick arm or switch arm. In any mode other than stabilized you shouldn’t be taking off until the throttle is above the center point.

That’s strange, it should work.

Better to send us a log with drone disarmed and trying to arm (LOG_DISARMED = 1) and a parameter list.

enabling feedback from mid stick in PILOT_THR_BHV worked, thank you

1 Like

thank you for being active here :slight_smile:
I’ve enabled feedback from mid stick to PILOT_THR_BHV and it works now. I’m attaching a log file anyway. bin log

The last time I flew/armed I was using firmware 3.6 and the mid stick was not enabled in param PILOT_THR_BHV. I guess now in firmware 4.0+ this is required.

Also here is a replay log, I would like to make sure that my servo output is ok sticks play - replay
The gif below shows the servo output when the drone is armed, the RC si at neutral (I am not touching the sticks), but in the log replay I am also moving the sticks.

When moving the sticks without the motors powered I sometimes get the message

Potential thrust loss(1)

I hope this is just because the motors are not powered. I’ve read in some cases that if this happens during flight, it may result in a total loss of control.

Another question I have is regarding the initial mode after startup. I have it as default in the parameters (INIT_MODE = 0/Stabilize) but it often goes to LAND when the FC boots up. I don’t think this is a problem, I’m just curious why that is (maybe an INIT_MODE bug?).

Sorry if this is too much for this thread! My drone is quite large (2.4m from propeller-propeller) and strong, so I’m a little reluctant to just try it out and see.

I also think so. It usualy happens in underpowered drones and can lead or not to loss of control.

Probably some failsafe is being triggered just after startup, it also happens sometimes with me, but changing to RTL, I do not think you should bother yourself about it.

Be careful at the first flight, follow all instructions listed in Arducopter docs for the very first flight.

Of course the Thrust Loss error is because there is no thrust. And it will Failsafe to Land, or whatever FS action you have selected, for the same reason.

Follow all pre-maiden flight procedures (calibrations, Initial Setup Parameters) put props on and fly it configured to collect data for Dynamic Notch Filter configuration.