Power module lit on fire inflight

Hello, so a weird thing happened to me today, and I don’t really understand it.
My power module fricking lit no fire while the drone was taking off!! That’s crazy!

I flown the drone about 5 times today, the first 3 flights good, and then I noticed a weird thing, the drone sometimes would take off, then the battery on the remote showed empty and the gimbal shaked. Thought that was a bug or something, landed, restarted and flown. No problem there.

After that I noticed that the two ground wires on the power module were like solded together. Was weird but I thought that it was just damage of some kind, and even then, I never paid attention to how they looked before.

10 minutes ago, I decided to make my last flight for today, and so good that I did, because I planned a flight over water for tomorrow, but now I’m so happy that this happened now and not tomorrow!
Here is what happened:

I took off, the gimbal started shaking again, waited for 10 secs, it didn’t stop, landed the drone, rebooted, started again and took off, I noticed a weird smell like something burning, started landing the drone and saw fire on it, upon landing I was surprised to see that the power module cables, the same ones that were kinda weird before, now were red-orange and burning!! :fire::fire::fire: I immediately dropped the drone from the air and disconnected the battery.

Upon closer inspection I saw that now the cables are totally un-isolated and burnt, the power module is probably broken, so no flights for now… I am just so grateful that I tried to fly again today!!

I will attach the image of the power module, how it looks now below, so I guess no flights for now!


Does anyone here have similar experiences? If so please share, and tell me if it is a good idea to try to fly the drone someday without the power module (I’m using an APM 2.8) or better order another power module, wait for it and then fly??

Thanks for reading!
Please share your thoughts on this situation!

Order a new supported flight controller from a reputable source, one that comes with a good power brick.

I’m not talking about the flight controller here, I don’t want to replace that, what I’m talking about is the power module!

Thank you for your response!

I’ve seen the CUAV HV PM that comes with most of their flight controllers do 80 amps continuous without a problem on 4 cell Lipo.
If you don’t want to buy a whole set (FC and all) then MRo have good power bricks

Okay, I will check it out!
But keep in mind that the cables that lit on fire weren’t the main cables, thankfully, instead they were the cables going to the flight controller.

Will check on the FCs and the PMs tomorrow!
Thanks for your help :slightly_smiling_face:

I suggest you look for a new power module… usually clones fail and the quality is not good.
Just look for the mRo power modules… the hardware is very solid

That’s a very bad sign, you will be looking for a new FC

Those are 5.37V and 3.3V level circuits. If those caught fire you likely have bigger problems. Smoking that obsolete Flight Controller would be a blessing in disguise.

Okay, I think it would be a good reason to upgrade my APM arducopter board. But for now, we tried to solder the XT60 directly to the PDB and it works just fine, for voltage monitoring I use a module for the FlySky FS-i6 receiver, I didn’t set any battery failsafes anyway, only radio failsafe, so I know when to land, my transmitter indicates the battery on screen.

As I said, I WILL upgrade in the future, for sure, but for now it seems like everything works as expected, I will fly 3 more times today and update you on how it goes!

Thanks for all of your help, everyone! I greatly appreciate it!

I flew 4 times today with no issues, except the battery lead being too short that required me to place the battery in a different position, that will be easily fixable by making an XT60 male to female connector, but in the future, when the mRo pixhawk kits become available again I will order it!

Thanks for your help, everyone :slightly_smiling_face:

Soon mro will release the classic zero… newer version of the pixhawk… more updated sensors and mcu…

I’d get a mauch adapter. Until the i2c adapters are mainstream (I have one that is epic but not commercially available yet) the mauch adapters are the best. The i2c digital adapter don’t require calibration and do all kinds of other estimation.

As for yours catching fire, you probably just put too much current through it. Get a mauch one to the current capacity you need and you won’t have to think about it ever again.

1 Like

I already put the power module in the trash! The power module was also burnt! Flying without it now, monitoring the voltage on my RC!

Yes. That’s what I understood from what you wrote. What I am saying is buy a mauch power adapter https://www.mauch-electronic.com/ they use Hall effect sensors and are some of the best and most reliable units made (for the time being). I use literally hundreds of them.

Just choose one that can withstand the amount of current you are using. No matter the brand of any power module, if you overload the current it can withstand, it will heat up and eventually anything will catch fire, desolder, etc. if you put 200 amps through something that can only handle 50 amps it’s just a disaster waiting to happen.

1 Like