Servers by jDrones

Plane dives at full power when switched to Auto


(RANND) #1

This is an Omnibus F4 Pro config, running Plane 3.10.0-dev in a Skyhunter. I maidened the plane in Manual and added a couple of clicks of elevator trim for level flight. I then used Autotune to update the roll and pitch gains. I loaded a 100M AGL rectangular circuit mission, launched and flew to 70M. I tested Stabilise briefly, then engaged Auto. The plane immediately arced up to full throttle and commenced a 20 degree dive. I was able to switch to Manual and save the plane with 6 metres to spare.

The PIDP data looks suspicious, but I cannot determine the root cause. Can someone have a look at the log and give me some advice? The fun starts 2 minutes into the flight.

https://www.dropbox.com/s/2z4jlfovzlycmjl/00000014.BIN?dl=0


(Nathan E) #2

Your plane was not responding well to pitch or roll demands from the autopilot.

Try FBWA before trying automatic mode. I doubt your plane will be stable in automatic mode until it is stable in FBWA. My guess is that your autotune did not do well for some reason. Be careful to follow the instructions precisely and be thorough with your autotune. Also make sure that you check servo movements: http://ardupilot.org/plane/docs/starting-up-and-calibrating-arduplane.html#check-servo-movements

and

http://ardupilot.org/plane/docs/guide-four-channel-plane.html


(RANND) #3

Thanks Nathan. Servo directions were fine. I will recalibrate the gyros and the radio, re-run Autotune for a longer period and confirm the results with FBWA before I try Auto again. This is my 5th Arduplane model and my 2nd Omnibus version. The others being Pixhawk. I have never struck these problems before. Perhaps the Honeymoon is over.


(RANND) #4

I repeated the Accel calibration making sure the FC was perfectly aligned for each stage. I then recalibrated the radio. Pre-flight checks revealed the problem. With the plane perfectly level, switching from Manual to FBWA with the sticks centred caused the elevator to deflect down 5mm.
This was the cause of my “dive”, I tried Arming the plane and with FWBA and SERVO_AUTO_TRIM enabled to see if the Auto-Trim function would work on the bench, but I saw no changes. I then resorted to adjusting the value of AHRS_TRIM_Y until I saw no elevator change as I switched between Manual and FBWA.
I took the plane to the field, took off in Manual and confirmed that FBWA was ok. I did not repeat the Autotuning. I switched to Auto to fly several laps of a rectangular circuit Mission at 100 metres. Altitude management and aircraft stability was good. Problem solved. Thanks for your help.