Servers by jDrones

Plane crash during Auto TakeOff

Hello,
I built a new Ar Wing Pro. But the maiden crashed during auto takeoff. I launched the plane using auto takeoff mode, and then suddenly pitched down and crashed into the ground.
Plane is rebuilt now, but before flying again, I would like to understand the reasons and how to avoid this from happening again.

Ardupilot version was 4.0.9
Matek 743 Wing FC

Here are the logs.
https://drive.google.com/file/d/1jNVW3JdLTPItpynm9A4qdmeNOtKNGcTU/view?usp=sharing

Video: https://youtu.be/uIJpnNRzvHc

I would appreciate any advice on why this happened and what changes can I do to fix this.

Thanks!

The Elevons output are both attempting full deflection to correct the airplane, but the plane instantly rolls. To me that suggests that there was a control reversal.

Thanks, Allister. I double checked rc and servo resersals. All seems correct.

  1. I reversed the Pitch to have a commanding pitch up result in higher PWM values.
  2. Verified FBWA automatic stabilization mode: Roll right: Left elevon goes up and right elevon goes down. Pitch down: Both elevons go up
  3. Verified the manual mode: rc pitch-up from transmitter and confirmed that the elevons both rise. Command a roll to the right from transmitter and confirm that the the right elevon rises and the left elevon lowers.

Should I reverse pitch from my tx16s instead of reverse the rc2_reverse in Mission Controller?

Does it fly nicely in manual or even fbw? I mean have you flown it without auto launch/auto mission?

No, should I try manual without stabilization?

Well it would rule out any reverse action of stabilization (though from what you’ve told us it would seem correct) and it would also rule out a really unstable aft CofG,
If you are comfortable hand flying a model or if you know of someone who is that can help you, it’s a good idea to get any fixed wing flying nicely in manual before you add in all the loop control of the flight controller, makes tuning easier later etc. For example ive set up an s800 recently and the factory balance is like 115mm from memory but it is wayy too nose heavy there and needs a heap of up elevon all the time, the fc will mask this out but it wallows around and wont fly slower. It needs to be 140mm or so. Against the recommendations of the instructions.

One thing I noticed today is the ekf has errror states. I reported in this thread. Not sure how to fix this.

How did the calibrations go? Did you the compass and accelerometers have any problems with calibration? After you plug in the battery did you move the plane? Is your compass and FC orientation setup properly?

It’s pretty normal that even once the HDOP value is low it takes a moment for the EKF lock in.

How did the calibrations go? Calibrations finished successfully.

Did you the compass and accelerometers have any problems with calibration? Compass disabled. accelerometers no issue with calibration

After you plug in the battery did you move the plane? No, leave it on ground and make sure no shakes.

Is your compass and FC orientation setup properly? Compass disabled. Point plane to North before plug in battery. Moving circle shows orientation is correct.

It’s pretty normal that even once the HDOP value is low it takes a moment for the EKF lock in.
I think EKF is red herring too. Today I put FC with GPS battery only in my car and drive to test it. After start driving, EKF is white, not more red state.

I compared crashed log with last successful log. One thing I noticed is the pitch angel during crash lauch is much higher than the successful one. Does that mean I launched it too steep?

What’s the best practice to launch Ar Wing Pro? Any tips? launch as level as possible? Do I need to throw it hard to get initial speed?

Thanks.

I haven’t launched an AR PRO, but I have an AR 900 so I’ll assume it’s going to be similar. I use the frisbee style throw so I’m standing 90 degrees to the direction I want the plane to go. I try to keep the plane wings level as possible and mostly level, with maybe a slight bit of nose up.

If this plane is new I would suggest having someone else throw it for you so you can focus on flying. Personally, I will maiden a plane in FBWA, But experience has taught me the hard way to have manual mode a switch flick away. Flying the maiden flight in manual mode, if you’re up for it, is never bad. As others have pointed out the FC will mask trim or c of g problems, until it can’t. I wouldn’t recommend maiden flights with takeoff mode unless you’re super confident in your build.

It might not also hurt to do the “Flite Test” chuck test. Before you fly the plane just throw it. I would have it in manual mode first, and maybe again in FBWA. If the C of G is correct it should just go in a straight line and settle in the grass. This way if some of the basics aren’t correct you’ll find out before it hits the dirt at full power.

1 Like

I wouldn’t call it a red herring. I won’t pretend I understand it fully, but the EFK system is a major part of what makes Ardupilot work so well. If it’s having issues then there’s a good chance you’re flight won’t go as well as you hoped.

1 Like

I followed your tips and got a successful flight today. So I can confirm the last crash was due to too steep when I launched the plane. Today I launched it as level as possible. The wing took off successfully. Thanks Allister.

I also tried manual mode when fly high enough. The plane diving deep when switched to manul mode. Does this mean it’s head heavy? I use the default CG point by sonic model AR wing manual.

Thanks in advance. It’s a great learning process. I’m new to this hobby. But I do enjoy build, test, analysis and redo it process.

1 Like

It could be trim or C of G, or a combination of both. In a perfect world both elevons would be lined up with the trailing edge of the wing and the plane would fly level at your cruise power setting.

But the world isn’t perfect, and it’s very common for flying wings to fly best with a couple of mm of upward deflection in both elevons. Wings are notoriously sensitive to c of g, and if you go too far aft the plane will not be fly. As was said earlier, the FC will mask a lot of that until it’s too late. If you’re going to adjust the c of g of the plane aft beyond what the manufacture says, do so with caution if you aren’t sure what you’re doing. The marks the manufacture puts on the wing are generalizations, and they will bias forward because it’s safer, so it is common to adjust aft of the limits, just be careful. The plane is flying now, so make your adjustments a few mm at a time.

This is some really general advice. Setting up trim and c of g is hard to describe without being there.
I always set SERVO_AUTO_TRIM = 1. This will automatically trim the controls in flight. You should start with the servo trims at 1500 and the elevons should be physically lined up with the trailing edge of the wing. After your flight look at the new trim settings for your elevons. If the trims are just a small bit out, then you can adjust the pushrods to Center the servos. If the trims are really far out then you should move the c of g a small amount and try again.

How much is a small bit or too far? It’s subjective. For me, if the trim values are within 50 (1450 to 1550) then I’ll often I’ll just leave it and won’t mess with it unless I’m in the mood to tinker more. Within 100 (1400-1600) then I’ll probably just adjust the rod ends to centre the trim. More than 100 and I’m going to start to look at what else could be the cause and that’s when C of G will come into adjustment.

Do not use the trims on your radio!! That’s for traditional RC planes and will only cause problems with flight controllers. Your radio trims must be set to zero. If you can, you should disable the trims in your radio so they don’t get accidentally adjusted.

2 Likes

I forgot to mention, when you do the chuck test (throw the plane and let it glide) notice how the plane lands. It should land pretty flat. If you notice it noses into the ground your C of G is probably too forward. If it porpoises thought the air then it may be too tail heavy.

1 Like

Thanks for the detailed information, Allister. I enabled the SERVO_AUTO_TRIM = 1 and tested it again today. But it crashed twice during takeoff. Could you take a look when you have time?

One thing I noticed is the Elevons are both attempting full deflections up and downs in the graph when the plane is level with small pitch degrees. Not sure why this happens.

20210302TakeOffFailure

Video: From videos, it seems the plane didn’t get enough speed and stale. Is this because I didn’t launch it fast enough?
Take off 1 crash: https://youtu.be/nOLtHyyA1Xs

Take off 2 crash: https://youtu.be/EB0lrGROnJU

Here are the logs:
https://drive.google.com/file/d/1TpJgMbOrxHYw6spPraVl7TsGz2aFaca_/view?usp=sharing

I’m on an iPad right now so I can’t view the logs. I’ll try later tonight or tomorrow morning,

Servo auto trim won’t do anything till it’s had 10 seconds if stable flight so that should have had an impact. I agree the launch looked slow and there’s that roll again. If the throw isn’t flat the plane may struggle to recover at slow speed.

Is your prop/motor/battery okay? I would expect that a new AR pro would have a little more pep.

Practice your launches in FBWA With the motor off. Throw the plane so it glides nice and flat. Once you’ve got that then try takeoff with power.

1 Like

Thanks, Allister.

The prop/motor/battery is okay. The voltage and Amps looks fine. The total weight is 1450g. It has a gopro and 4s2p 21700 battery. It may be too heavy.

I got the OSD record today. OSD video shows speed is not fast enough.
Here is the OSD video:

Today is a calm day. Compared with yesterday video, yesterday has 10km/h head wind when took off. That may help the successful take off yesterday…
Yesterday successful video with OSD

I will do the FBWA with power off test tomorrow.

Hi mavic,

Your failed takeoffs are related to a too soft throw.
Just compare the achieved launch speeds at the failed launches and the successful one.
With a takeoff weight of 1.45 kg the plane wants a stronger throw.

Hope this helps.

I tried again to use FBWA to launch today. But it failed again.

Here are logs and OSD/FPV video:

https://drive.google.com/file/d/1CjyseDRI0PEmoyAO1ockN1SvFIQTkzOX/view?usp=sharing

It seems it still didn’t get enough speed. It’s a calm day. Any suggestions? How can I launch it hard enough? Thanks in advance.

Motor off and more practice throws. If you throw it from 1m high, it should land 5+ m away from you nice and flat.

The light isn’t good in this video but watch how the throws it. There’s a good burst of speed as it goes. Work on keeping the wings level.

Servers by jDrones