Plane 4.2 stable release


I’ve just released plane stable 4.2.2. This is a minor stable release with a few new features and bug fixes. Just one change since beta1.
The biggest change is the enabling of the full dual harmonic notch filter, which is a major benefit for quadplanes with internal combustion motors, allowing for tracking the RPM of the forward motor with a separate dynamic harmonic notch filter from the VTOL motors.

The full list of changes is:

  • support two full harmonic notches using the INS_HNTC2_ parameters
  • adjust neopixel bitwidths for better reliability
  • fixed EKF3 replay bugs that caused poor replay fidelity
  • added BLHeli_S ESC type in SERVO_DSHOT_ESC
  • reduced min lean angle for alt-hold in quadplanes to 5 degrees
  • fixed param ftp run length encoding bug
  • reduced default quadplane rate accelerations and XY position gains
  • improved parameter checks of Q_M_PWM parameters for bad conversions
  • added Q_NAVALT_MIN parameter for min alt to start attitude control in takeoff
  • added CAN_Dn_UC_POOL parameter to control DroneCAN pool size, to allow memory saving on F4 boards
  • saved hardfault crash dumps to microSD if detected
  • fixed PWM rangefinder bug and support SCALING parameter
  • updated OSD flight modes menu for newer modes
  • preserve new rangefinder addresses on VL53L1X
  • protect against hardfault on bad CRSF frames
  • handle reset of CRSF receiver in flight
  • added MambaH743v4 and MambaF405 MK4
  • fixed fault on FFT init with ARMING_REQUIRE=0
  • synced quicktune lua script with latest version
  • learn MAVLink routes on private channels
  • fixed throttle compensation with FWD_BAT_VOLT_MAX at low voltages

Happy flying!

3 Likes


Hi @tridge Thank you for plane v4.2.1, automatic CAM triggering when FC is rebooted is not happing now. But CAM_messages are showing lot more then actual photos taken in mission. this is not happing with v 4.0.9 version.

Thank you for all
Mohan

For log and photos use this link

https://drive.google.com/drive/folders/1G_2abMWOPo8rhiyjxHU8uwAWz_hWGdZG?usp=sharing

can you add a log from 4.0.9 where it is working as you expect?

How to remove "PreArm: In landing sequence’’ option from the arming checklist ?
Is it possible ? because I didn’t find this in pre arm check list param.
Please help me out.

1 Like

Upgraded my VTOL to 4.2.2 from 4.1.7 ( 30 + flights ) first flight after upgrade.
T -Tail 4 x T - Motor U5 & Alpha ESC
take off in Qloiter fine then cruise then loiter couple of turns then Qhover all fine then Qloiter to land, constant ccw yaw, no stick inputs quick decent held position but very fast constant yaw. noticed that motor 1 was at 1300 PWM and motor 2 was at max 1950 PWM throughout the yaw. I have bench tested the motors under load fine. The FC was sending signals to the ccw motors min & max dont have a clue as to why. Can any one help me. Here are the Tlog Data flash log and the VTOL params. The logs are long they start at 68%
Here is the google drive link to the logs and params
https://drive.google.com/drive/folders/1jNdpDKrsJd0NKtTODWYSXOMyMivzepqp?usp=sharing

Hi Mark,
You definitely lost power to the rear-left motor.
Here are the motor demands:


Here is a motor model of predicted current compared to the actual current draw during the takeoff and initial flight:

you can see that the DC motor model predictor does do a very good job of predicting the current draw on your VTOL motors
and here is the model for the final part where you lose a motor:

you can see the point where it diverges very clearly
and here is the motor model prediction if we subtract off the prediction for the failed motor:

you can see that it does match at times, but is “stuttering”.
What is almost certainly happening is PWM signal corruption. On high motor demand (most likely on rapidly changing demand) you are either getting ground lift or getting switching noise from the ESCs causing signal corruption.
To try and reproduce this on the ground you need to give a sudden motor demand. Strap down the vehicle and use MissionPlanner to do an 80% motor test of one motor for 5 seconds with the propeller on. If the motor stutters at all then you have a signal corruption problem. Correct operation is to go to a constant RPM for 5 seconds.
To fix the issue you can do several possible things:

  • set BRD_PWM_VOLT_SEL to 1 to use 5V signalling on the 8 MAIN outputs of the cube orange. This will give you more signal margin and make the issue less likely
  • set Q_M_SLEW_UP_TIME and Q_M_SLEW_DN_TIME to 0.2, this will slow down the maximum ramp of the motors, which tends to be what causes the issue
  • change your wiring to ensure the PWM signal cables are not running close to either motor power or the 3-phase motor wires
  • shield your wiring
  • switch to CAN ESCs

Hi Tridge,
Thankyou for detailed analysis of my logs. You nailed it, i was able to reproduce the stutter via mission planner 80% motor test 5 out of 6 attempts on rear left motor ( other motors fine ). I tried changing the params you recommended no difference. FYI here is a log of the stutter after param changes. i will have to go through a process of elimination to find out the prob, motor,ESC or wiring. At least i now no what happend.
Cheers Mark
https://drive.google.com/file/d/1MVCsP26Hij3SUJRQKelb55HfzTYbON-7/view?usp=sharing

great, thanks for letting me know. Please follow up with what you do to solve the issue.

Hi Tridge,
swapped the motor/esc to the other side of the plane ( different wiring loom ) still stuttering. I have sent link to some photos. the ground signal wire has melted its insulation. and sitting over a big transistor dont know why.
https://photos.app.goo.gl/8PbMjjn8XBkmFp7r8
Google Photos
the first photo is how i found it out of its case

hi Mark,
I think this would be worth breaking out as a new topic. Then I’d suggest we ask @Leonardthall to comment on how to fix the grounding issues. The ground wire melting means you’ve got a lot of current flowing on ground.
Start a new topic so we leave the stable 4.2 release topic for it’s main purpose.
Cheers, Tridge

Hi tridge,
I am running the signal ground off the ESC power ground ( foxtech wiring ).?

Google Photos

@tridge Sorry for the late reply… that data is corrected, sir. next time I will send logs.
Thank you
Mohan

Hi tridge,

I have setup a new topic.
Grounding issues

1 Like

Hi all,
I’ve converted a plane from INAV (more than 50 flights without any issues) to Ardu stable. Quite successfully. However, I’m still an Ardu beginner… and ran into an issue…

BOM:
-Flux wing
-Matek 405 Wing (no sd card)
-Crossfire 4.10
-Blheli_s
-DJI FPV
-Banggood GPS NEO 8M

  • 2 x digital PTK servos

On the bench/outside I had the issue I could not arm due to GPS unhealthy. I had 10 Sats:

15.07.2022 09:46:30 : PreArm: Logging failed
15.07.2022 09:46:30 : PreArm: GPS 1: not healthy
15.07.2022 09:46:29 : PreArm: Logging not started
15.07.2022 09:45:59 : PreArm: Logging failed
15.07.2022 09:45:59 : PreArm: GPS 1: not healthy
15.07.2022 09:45:45 : PreArm: Logging not started
15.07.2022 09:45:36 : AHRS: EKF3 active
15.07.2022 09:45:28 : PreArm: Logging failed
15.07.2022 09:45:28 : PreArm: AHRS: Not healthy
15.07.2022 09:45:25 : PreArm: AHRS: Not healthy
15.07.2022 09:45:13 : AHRS: DCM active
15.07.2022 09:45:09 : AHRS: EKF3 active
15.07.2022 09:45:08 : AHRS: DCM active
15.07.2022 09:43:28 : PreArm: Logging failed
15.07.2022 09:43:28 : PreArm: GPS 1: not healthy
15.07.2022 09:43:22 : PreArm: Logging not started
15.07.2022 09:43:12 : IMU0: fast sampling enabled 8

That was without a SD Card inserted. So I disabled logging:
LOG_BACKEND_TYPE,0
LOG_BITMASK,0

because actually I don’t need it. So arming was then possible straight away. Yay!

Wing was flying great out of the box on Ardu maiden. When I started Autotune routine the control surface started to freeze randomly not always but after right left/left right procedure sometimes.

I’ve decreased the servo hz from 300 to 50 but still had freezes. (initially I thought the 405Wing BEC was overloaded, but hey we are talking about 2 servos…) Back then it was the third flight. So, I’ve enabled logging again and put a SD card in it and put the servos back to 300hz. Took it for a fourth flight today and no freezes at all. Whatever I do it flys flawless in all modes + Autotune.

@tridge
Attached by is my latest param from today
Flux_latest2.param (18.5 KB)

I’m not sure if this is worth looking into, but I thought it was quite scary.
Thank you for this great piece of software and that you share it with the community !!!

Best,
Seb

@tridge, the question in @sibi’s case is whether a missing SD card or switching off logging can lead to a servo freeze?

Doesn’t anyone have an opinion on the problem?

I have a problem with the camera trigger, I use a pixhawk 2.4.8 controller, arduplane 4.2.2, Canon G9 X Mark II camera.

I haven’t used this controller and camera for a long time, but with previous versions of arduplane everything worked correctly, especially the camera trigger, the settings I used were the same as in this tutorial (Index of /copter/docs common-pixhawk-camera-trigger-setup.html).

Now I’m using this equipment again and I’m updating it to the new arduplane 4.2.2 version, but I can’t make it work, the settings I tried were those in the images below.

But I can’t shoot the camera by the command “Trigger Camera NOW”

Can anybody help me?

My parameters
Parametros Drone Horus_-20220801-_1250hr.param|attachment (16.0 KB)

Hi tridge,the plane become unstable in FWBA mode in case of losing GPS. I once lost GPS during a flight, and the plane became very unstable and difficult to overcontrol. I switched back to manual and kept flying until the GPS was restored and the plane was stable again。 But unfortunately, there’s no flight log。I set the Tecs_synsthetic speed=1。I don’t know if this is the cause of the flight instability, normally FWBA mode does not require GPS signal , Is there a logical hole in this?@tridge

Could someone provide a parameter file where the camera trigger works correctly? so i can compare it with mine and see what could be wrong.

1 Like