Plane 4.2 stable release

I’ve just released ArduPilot Plane 4.2.0 stable. Since 4.2.0beta6 there have only been 3 changes:

  • added VTOL-quicktune lua script
  • fixed custom compass orientation for DroneCAN compasses
  • fixed a bug in blended Z accel calculation when not using first IMU

Since the last stable 4.1.7 release there have been over 4k changes,
so it is not practical to list them all here. Highlights for plane
users include:

  • smoother quadplane transitions
  • ship landing support
  • CAN over mavlink support
  • major tailsitter improvements
  • much better error reporting and diagnostics
  • numerous lua scripting improvements
  • improved weathervaning support and options
  • support for fixed wing aerobatics
  • many new flight controllers added
  • DroneCAN dual-GPS for yaw support

Full change list here: ardupilot/ReleaseNotes.txt at master · ArduPilot/ardupilot · GitHub

Happy flying!


Thank you!

@tridge apparently the custom firmware server is stuck again:

thanks! I’ve restarted apache2 and it is going again

1 Like

Hey @tridge , mostly a lurker around here but wanted to thank you and the team for the mountain of effort that goes into these releases! :man_bowing:

I had some observations and wanted to understand a couple of things regarding release notes:

  1. In the Mission Planner notification about the update available for the new release, the link takes me to this page on the forums

  2. I couldn’t find anything related to the Plane 4.2.0 stable on that page. That page has the links to the Copter & Rover releases. I did find Plane 4.0, but not Plane 4.1 and 4.2.

  3. I did find the release notes for 4.2.0 in the repository master branch in ardupilot/ArduPlane/ReleaseNotes.txt I’m guessing this is the correct place to look for the release notes?

  4. The major changes from 4.1.7 → 4.2.0 would be all the beta changes & the final changes in the 4.2.0 release?

Thank you so much!

1 Like

thanks! I’d forgotten the stable-release tag, now fixed




Also, I’m unable to see the 4.2.0 release on the GitHub releases page, is this normal?

So I’m trying to understand the development process (especially between releases), and was curious:

I completely understand it’s impractical to list down all the changes that have happened under the hood, in the release notes. However, if I wanted to see the changes would that be on GitHub (whether it’s merged PRs, issues fixed, etc)?

Let me know if this is not the correct place for this post, thanks.

I’ve added it now, thanks

for the full list you’d need to use a git tool to look at the differences between 4.1.7 and 4.2.0. There are over 4000 commits in that set, so a lot to look through!

No worries, happy to help :smile:

Understood, thank you so much for clarifying!

I’m seeing problems with 4.2 stable on my Matek H743 wing v2. I programmed the “arduplane_with_bl.hex” file using STM32CubeProgrammer and when it was done I unplugged the USB cable to the FC and plugged it back in. It gave a cheerful series of beeps but then gave a single continuous beep and MissionPlanner was unable to connect to it.

The 4.1.7 load works fine.

Hi all I have some issues after updating to 4.2
all worked fine under 4.17

I started to update my fleet Cube orange with Hex power brick
after doing so i lost my rssi not working on the first plane


and all so the current sensor has stop as well
But the voltage is working


so moved on the next plane same issues
so i roll it back 4.17 all works

all of my orange cube show the same issues

1 Like

@yak-54 can you give me a log (bin log or tlog) of it working with 4.1.7 and another log of it failing with 4.2.0

Hello Andrew his is all i have at this time in logs
i did get the rssi working on ADC so I know its not the receivers
and i did change power brick to new still no joy
so then i did try and old 3dr power module i had and it works fine on the orange cube

Hello developers!

I updated the firmware to 4.2.0, a message appeared on the screen: Getting Param MAVFTP 1-1:@PARAM\param.pck. Please explain what this means. On the Matek 743 flight controller, this message disappears quickly, on another Durondal this message within a minute. This message has a normal event or there is a problem with the firmware?

I liked the new firmware functions, it is very convenient for quickly setting up the flight controller, for example, TRIMRC / SERVO SAVE, I really dreamed of having such a tune option. Thank you for your great work!

that is MissionPlanner fetching your parameters using the MAVFtp protocol. The MAVftp way of fetching parameters is approximately 10x faster than the old method (varies with type of link)
It is normal for this message to appear. If it stays up for a long time you may need to update to latest beta of MissionPlanner which fixes an issue with MAVftp


Thanks @tridge and the whole development team!

Hello! I am also experiencing issues with similarly configured rxrssi (rssi pin 103, voltage range set to 0.38 to 3.3). Looks like SBUS pin problem. Updated from 4.0.9 to 4.2.0. Board - chinese clone of Pixhawk (common 2.4.8). Before rxrssi was working flawlessly, after update 0 all the time. If you need another logs, tell me.

thanks Colin.
I checked the logs, and I’m seeing zero current (under 0.001 amps) with both your 4.2.0 log and your 4.1.7 log.
I also loaded the parameters from your 4.2.0 log onto a CubeOrange here with a standard yellow power brick and it did read current and voltage correctly.
I have reproduced the RSSI issue, and I have a fix here:

I’ll include this fix in 4.2.1
Thanks for reporting the issue!

updated firmware with RSSI fix here:
please test

Any thoughts on my previous error report a few posts back? After booting up it gives some cheerful sounding beeps then just sits there emitting a constant tone.

sorry for the slow reply.
I flew a plane with a MatekH743-Wing (v1) yesterday with no issue on 4.2.0.
I just loaded a H743-Wing v2 now via STM32CubeProgrammer from arduplane_with_bl.hex. Interestingly, on the first boot it did as you described, beeped and didn’t show up a port to connect to. Power cycled it again and it was fine.
One thing about the MatekH743-Wing is it stores parameters in the last 2 sectors of flash, so updating via DFU doesn’t wipe parameters. Can you try resetting parameters first then updating? Do that either by loading 4.1.7 and setting FORMAT_VERSION to 0 or by loading a different vehicle type (eg. copter).