Plane 4.1 stable

I’ve just released plane stable 4.1.7. It will take up to a full day for this to appear in firmware downloads (our firmware build server is heavily loaded at the moment).
This is a minor release with some important bug fixes and a couple of
new features:

  • avoid all opening of log files in main thread
  • support Benewake CAN Lidars
  • improved VTOL navigation shaping code
  • Compass custom orientation is never overwritten during calibration
  • EKF logging gaps fixed (some messages were occasionally being skipped)
  • IMU logging fix for IREG message (records IMU register changes)
  • SERVOx_FUNCTION protection to avoid memory overwrite if set too high
  • FTP parameter download fix

Happy flying!


If Q_RTL_MODE = 1 the plane will transition to QRTL if distance to home is less than RTL_RADIUS - the case you described.

From my experience this situation is best handled using Q_RTL_MODE = 0.

This requires to use DO_LAND_START in your flight plan, but gives most consistent behaviour.
You can “force” the presence of DO_LAND_START event in flight plan by enabling appropriate bit in ARMING_MIS_ITEMS parameter.

1 Like

I have question related to position control via L1 controller.
I have seen this in plane documentation:

  • the L1 controller converts a origin and destination (each expressed as a latitude, longitude) into a lateral acceleration to make the vehicle travel horizontally along the path from the origin to the destination.

As I understood the L1 controls the vehicle travel horizontally. Is it possible to change/tune it to be able control vertically as well?

1 Like

Thank you for your suggestion and I just tried that out and working well when I set Q_RTL_MODE= 0 ,always follow DO_LAND _START regardless of RTL and WP_LOIT_RAdIUS.

I have set RTL_ radius = 80m, Q_RTL_MODE =1 and WP_LOIT_RADIUS = 200m.

With above set-up test definitely RTL should follow the DO_ LAND _ START command as RTL radius is less than WP_LOIT_RADIUS. so there is no chance of direct QRTL.

second test i have setup RTL_ Radius =0 and Q_RTL_MODE =1 and WP_LOIT_RADiUS = 100m.

With above set-up RTL command directly executed QRTL while loiter over the home point.

Set WP_LOIT_RADIUS to 150 again same result QRTL instead of Follow DO_LAND _ START.

Next test set up WP_LOIT_ RADIUS 180m but this time when I gave RTL it’s start following the do land start command. Why this difference happened?

NOTE: all RTL given when loiter over the home point ( landing point).

Please I need clarification on this.

It seems there is now no Fence Breach message with 4.1.7. I get a “change mode to RTL”, but no message that says why. It was a fence breach, I know because I did it deliberately. Is this supposed to happen?

This is the data flash log: Dropbox - log_67_2022-3-3-17-19-04.bin - Simplify your life

This is the tlog. It includes several other flights (including an autotune), as well as the flight above which includes several deliberate fence breaches: Dropbox - 2022-03-03 17-38-19.tlog - Simplify your life


Just upgraded a build from 4.1.6 to 4.1.7 and the VTX keeps getting put back into its restricted mode. If I pull the smart audio wire I can get the vtx unlocked and to any power. But if I return the wire it locks the vtx again and doesn’t respond to my power on a switch. I have the vtx options on unlocked and nothing was changed.

@Will_Fisher I’m not really an expert on the VTX logic changes. Maybe @andyp1per will have some suggestions?

Can you provide some more details on setup. I am not aware of any VTX changes between 4.1.6 and 4.1.7

The osd element is flashing 25mw and wont change even if the message scrolling past says something different.
18/03/2022 2:36:37 PM : VTX: F8 5880MHz, PWR: 25mW message keeps coming in MPlanner.
vtx = tbs unify pro hv



Arvo all
can some test this issue on 4.1.7 i have

I am trying to set a flight mode to RC13 = 107 that’s autotune for fixed wing on switch
it will not go into autotune
so i tried another mode RC13= 4 RTL and i tested it RC= 24 auto pilot on that switch works fine
and then i tested autotune as a flight mode works fine just will not work on a RCIN channel

this option doesn’t start AUTOTUNE as a flight mode, it enables the autotune functionality in other stabilize flight modes. For example, you can use it in LOITER, AUTO or CRUISE modes. Once it is started you then use stick mixing (enabled with STICK_MIXING=1) to give the necessary disturbances to allow autotune to operate.


What TBS firmware version do you have?

I thinks it’s a smart audio v1 on the original unify pro HVs and as for crossfire I have v6.16.

Tried a second vtx and it seemed to lock it back up after having unlocked it

6.16 is the problem - I am still working with TBS to resolve these problems. Stay tuned

But the smart audio is connected to a spare serial? 6.16 is affecting the FC?

There are bugs in the latest versions of TBS firmware that affect both smart audio and CRSF. Until those are resolved I won’t be able to look at any SA or CRSF issues of this nature.

Thanks Andy, hopefully it’s sorted soon! Weird that it doesn’t work connected to a UART

Hi @andyp1per

Can you recommend any older TBS firmware which is known for less problems with SA and CRSF?

Do de-transitions with Q_GUIDED_MODE = 1 use this new multiple-phased logic or still start at WP_LOITER_RAD metres away?

Hi all.

I have a bug/problem with logging.

Latest stable arduplane on a Matek h743-wing (sd card logging worked flawlessly on (I think, 4.1.0 version)), after updating the arduplane version to 4.1.7, did a long-ish flight, at home, connected the plane (FC) to (latest stable) MP through USB and tried to download the log file, log downloader does not see it. I took out the SD card, Windows is seeing it in log folder, I can save it locally and I can transform it with MP, bin to log.

Why can’t MP see/download it through it’s dedicated program?