Plane 4.0 release

I’ve just released plane 4.0.1. This is a minor release with a few bug fixes and enhancements over 4.0.0. Changes are:

  • Added Q_ASSIST_ALT parameter which offers a way for VTOL assistance at low altitudes
  • fixed channels 5 and 6 on the MatekF765-Wing
  • fixed a bug with sending data on a full UART in mavlink parameter download
  • fixed use of UAVCAN primary GPS with UART secondary GPS
  • fixed failover between rangefinders of same orientation
  • added RC option for TAKEOFF mode
  • fixed logging of current on secondary battery monitors
  • fixed register checking on DPS280 for mRoControlZeroF7
  • added clock panel to OSD
  • fixed B/E led brightness on Pixhawk4
  • support RTCM injection to UAVCAN GPS for RTK support
  • fixed an RC failsafe bug that could cause the geofence to disable
  • fixed a bug in the SDP33 airspeed driver

Thanks to everyone who tested the 4.0.1 beta release!

Happy flying!


I understand you and I know what can be done, but my problem is that I only have 12 channels and all are busy, if I have to use a channel just to change panels, it is a bit absurd. If the function I request, could be implemented, we would save a channel for those who do not use more than a single panel. Greetings

first, thanks for the continuous development of this fantastic software.
My question: I’ve installed plane 4.0.1 release but I don’t find the TAKEOFF Mode in the Flight Mode list.
Am I missing something ? Is it a parameter to set in Parameter List/Tree only ?


It’s there, update Mission Planner to latest Beta.

Hi Dave,

thank you.


Have you checked how the auto takeoff procedure of the MyFlyDream autopilot works? Would be great to have something similar for hand launch.

Hi Corrado- I have enabled Takeoff mode on a Nano Talon but only tested int indoors with no props and in the SITL. The props spin up from throwing acceleration so it should work. Weather is bad here to try it for real. I think if you have it working in a mission it will work as a mode.

While it is possible that updating MissionPlanner will help, what you probably need to do is tell MissionPlanner to rebuild it’s parameters. Open the Control-F menu, then select “Param gen” (it is 7th down on the left side). Then leave MissionPlanner running for a couple of minutes. After that restart it and you should find that TAKEOFF has been added.


@tridge Can you write a guide for Porter,I want to learn how to using ICE,or just SITL?

there is some documentation here:

1 Like

Now it works

Thank you

I’m not able (in v4.0.1) to find parameter SCR_ENABLE to start playing with the scripts (more specifically, to have more freedom for my in-flight glow plug igniter (winter is cold here!)). Is there something else that needs to be enabled to access scripting?


  1. Can scripts be updated remotely via MavLink?
  2. Are there any “spare” parameters (call it user params if you want) to be used in scripts? These could be easily changed from the ground station to give more flexibility to the scripts.

Thinking of a glow plug igniter, I’d could use one of these user parameters to store the PWM of the throttle below which I’d like the igniter to be on… It could then be easily adjusted from the ground station.

Hi Nicolau, which flight controller do you have?
For scripting the flight controller requires over 1 MB. SCR_ENABLE is therefore not displayed on a Pixhawk 1 or a Matek F405, on modern Pixhawks with 2 MB or, for example, the F765 wing, the parameter is visible.


Hi Rolf. I’m using a Pixhawk 2.4.8… As far as I know, it has 2MB as per the STM32F427 datasheet (here on page 76).

Is there a way to see what is the actual hardware? With all these clones around, I sometimes don’t trust what the seller says and in their web they have the same product with different specs :upside_down_face:

Older Versions signed V1 or V2 on the chip had a bug with only 1 MB usable.
Arduplane compiles two versions: Pixhawk 1 and Pixhawk 1-2MB:

I have another one around but it is still with 3.9… I’ll dig further. Thnx!!

I have a 2.4.8 on V4.0.1 and those parameters are available. This is just sitting on the bench, I don’t know if the functionality actually works.


Thanks Dave!
I tried Randy’s procedure to check if this board was affected to no avail (I guess the NSH is no longer valid in ChibiOS).
I updated to v4.0.1 the other Pixhawk I have and the SCR_ENABLE is there, meaning I do things right and that the former Pixhwak I tried surely has the 1MB flash bug (interestingly, I bought that one recently… sellers probably have a stock of these).
Thanks for the hints, guys!

One of the best Flight controller ever released out in the market. Proud to own one.
Congratulations for the team!

I’ve just released plane 4.0.2beta1. This is a minor release with a few bug fixes and enhancements. Changes are:

  • added new COMPASS_SCALE parameters and estimator to fix issue with compass in Here2 GPS
  • fixed issue with millis wrap on boards with 16 bit system timer (MatekF405, MatekF765, speedybeef4 and KakuteF4)
  • fixed i2c internal masks for several boards
  • fixed scaling of Blheli32 RPM conversion
  • changed to WFQ FrSky telemetry scheduler
  • enable LED pin on MatekF765
  • added params for Durandal battery monitor pins to param docs
  • updated bootloaders to reduce change of line noise stopping boot
  • fixed DMA error causing memory corruption in ChibiOS I2C driver
  • fixed param conversion from plane 3.9.x to plane 4.0.x for rangefinders
  • cope with UAVCAN GPS that doesn’t provide AUX messages (Here2 GPS)
  • send temperatures for IMUs on mavlink

Happy flying!