Plane 4.0 release

Hello, where will be available new information or parameters for this Version 4? Is this supposed to be mixed with old information on or there is another way to find just this update info? thank you!

The wiki has already been updated with documentation for most features in plane 4.0. There is still some work to be done, but most of it is there.
See the first post in this topic for a list of changes.
Cheers, Tridge

@tridge I was able to make our tilt-wing VTOL takeoff just once, with the 4.0.0 table release, but all attempts to reproduce it end up crashing AP/SITL, as soon as I select SIMULATION/model/xplane in MissionPlanner and click on the green plane icon. I also tried flying the 747-400 with the params and sydney waypoints I found thru a link here, and I have run into a similar issue (also with 3.9.8). I have rebooted, reconfigured and rebuilt AP/SITL after distclean etc., but they don’t help.
Here is a cut and paste of the terminal output:

Waiting for XPlane data on UDP port 49001 and sending to port 49000
Starting sketch ‘ArduPlane’
Starting SITL input
Using Irlock at port : 9005
bind port 5760 for 0
Serial port 0 on TCP port 5760
Waiting for connection …
Connection on serial port 0
bind port 5762 for 2
Serial port 2 on TCP port 5762
bind port 5763 for 3
Serial port 3 on TCP port 5763
Home: -35.363262 149.165237 alt=584.000000m hdg=353.000000
Connected to
X-Plane home reset dist=20877940.000000 alt=37.2/580.4
validate_structures:414: Validating structures
[Inferior 1 (process 47) exited with code 0216]

I’d appreciate any pointers you can give in getting over this issue. Thank you.

Hi will 4.0.0 support 2 GPS units
like here2 on the can-bus and backup GPS here on GPS port2 ?

can you send me your xplane model and params and I’ll try?

yes, all versions of plane support dual GPS

@tridge Thanks for the quick response. Unfortunately, I don’t have the permission to share the tilt-wing VTOL xplane model in any public forum at this point. However, I ran into almost exactly the same kind of problems with the 747-400 on X-Plane with your sydney waypoints and params I copied from Since my original post yesterday, I have not crashed the AP/SITL when trying to fly the 747, but it never flies the mission. Much of the time, the 747 just sits and does not move; other times, it would start moving and wander off and crash. Another mode of failure is that it would takeoff, but soon roll to one side and lose altitude rapidly and crash. Also, I have run into the same problems with AP 3.9.8, which is why I wanted to try 4.0.0. Here is a link to log files from two runs:!Ar12eAaJ73aLimFYU3LJ3Os9pJZZ
Could it be that 747 params file needs to be updated for use with the newer AP releases? I greatly appreciate any help.

@tridge Good news! I have now flown the 747-400 with the sydney waypoints and params I copied from a few times, it looks like it is following the flight plan (with wild swings), but it takes forever, compared to the time in the you tube video. It is in Auto mode, and I didn’t touch anything once it started moving. The only difference I can think of between these successful attempts and the previous ones when the 747 just sat there, is that I waited until the “ARMED” status disappeared from the HUD (in Mission Planner) before I pressed the “Auto” Actions button. Doing this trivial thing, my tilt-wing VTOL plane also takes off every time! Even during these tests, I saw one crash of the AP/SITL when I got tired of waiting for the 747 to complete the mission and pressed RTL a couple of times. In any case, thank you for taking the time to respond to my post.

@tridge I still don’t understand the AP/SITL crashes at odd times. It would be nice to have stack dumps to post here, but I haven’t figured out how to get gdb to do that for the “Inferior process 0” which it says exited.

Hi @tridge , sorry for the late reply, here are the params
Omega Prototype Params for tridge.param (18.9 KB)

EDIT 1: It seems like its the SDP33 Sensor connected to I2C2 causing the reboots, I disconnected it and it does not reboot anymore.

EDIT 2: its only rebooting with the SDP33 attached. Cable and sensor is OK , tested with a second new one.

EDIT 3: I set ARSPD_BUS=1 (instead of 0) and it is not rebooting anymore with the sensor connected

EDIT 4: Also not crashing when set to “2”, only crashing at “0”
Airspeed not working on any of them… :frowning:

EDIT 5: Exact same setup with AP3.9.8 is working flawlessly and airspeed is working too, so must be a Bug in 4.0.0

ok, thanks. Unfortunately I’ve misplaced my SDP33 I used for testing. I’ve now ordered another one from drotek.
It is likely a watchdog reset. Can you set LOG_DISARMED=1 and get the log both before and after the reset?

For my SDP33 from drotek plugged into I2C2 on the cube carrier board, I use the following parameters:


I have had no problems on the Beta releases of 4.0.0, but I haven’t actually loaded up 4.0.0 stable yet.

ok, thanks Nate. Can you try with the params that @palm369 posted with the stable release?

I’ll do that in a few hours. Before that, @palm369, check the I2C cable… I have found some weird things going on from Drotek cables, especially when splicing. Wire markings vary from cable-to-cable.

actually, I’d prefer he didn’t fix the cable, if it is a bad cable then I want to find out how it causes a reset. If he fixes it then we may lose the one example we have :slight_smile:

Its not a hardware issue, I tested that.

I am sorry but I cannot send you any log because the plane is in productive use now on 3.9.8 maybe I have time to use our “test” plane for that.

I can confirm @palm369’s issue… I am using a cube orange and a mini carrier board. Continuous reboots. Logs here:!AunBK4rE1ZDCgcgjiW712ywQCz52uw?e=0mcXDc

Thanks Nathan! I was just preparing for testing myself again.

I can also confirm that this is not an issue with 4.0.0 Beta 2, and this is the same issue both Cube Blue(black) and Cube Orange. Kind of frustrating that the stable release as a bug when the last beta I tried didn’t… Guess I should have done beta 3 and 4.


I was able to find new documentation in WIKI about this subjects:

• in-flight compass calibration:

• added AFS_MAX_RANGE for limiting vehicle range:

I am very interested in this feature, but I wasn’t able to find documentation about this: “support for additional RC input on any UART”

Could anyone? Regards.-