Plane 4.0 release

Only F7 processors support inversion of serial ports:

I read that as swapping the functionality of the TX & RX pins on F7 boards - - not inversion??
What does InvertRX, InvertTX do on F4 boards?

Some F4 boards have external inverters; the PixRacer has one for UART8, but the MatekF405 has none. But the F7 processor has built-in support for inversion of all uarts.

I use an inverter cable with my F405-Wing:

On most of the F4 boards nothing…

I have a converter cable in another Pixhawk based model, but seeing as I do need another receiver for the F405-Wing, I will get one which provides a non-inverted Smartport signal, such as R-XSR which has a solder pad just for that.
Tx for clarifying.

@tridge Two Bixler 2 missions using Beta 4. One in Auto that ended prematurely; I believe due to an airframe serviceability issue rather than the autopilot. Second mission is just in FBWA including some experimentation with full flap for landing. Gusty with 11-13kts wind.

Beta mission logs

1 Like

I wonder if Preflight_calibration could be added as one of the RCx_option ?
I use this function after a couple of minutes from power up to calibrate baro/airspeed after the sensors had a chance to warm up.
It would be nice to be able to do this from the remote and not have to power up laptop/mission planner for a quick test flight.

1 Like

I’m delighted to announce that stable 4.0.0 plane has now been released. Many thanks to everyone who has been testing the betas, as well as a huge thank you to @hwurzburg for the massive effort he has been putting into getting the wiki ready for this release.
I expect that as the number of people flying the 4.0 release goes up that we are likely to get a series of small releases in the 4.0.x series quite quickly. Meanwhile the effort towards the 4.1 series has already started in master.
If you don’t know what is new in the 4.0 series then please look further up this chat for the release notes for beta1.
Happy flying!


You can do this using Qgroundcontrol from an Android phone.
You will need to install Bluetooth module.
I have documented my own experience here:


BUG: With plane 4.0.0 Stable and the here2 via can the CUBE keeps in a bootloop when you set everything up and “GPS_type = 0” instead of “9”. You can not connect to the Cube then till you unplugged the GPS from the CAN port.

Side note on that, I’m not sure why “Auto” doesn’t work for the CAN Gps… at least it’s not clear from the documentation unless you dig through the Cubepilot forum.

Thanks, that is indeed a good solution, I was thinking for the case when you don’t have telemetry.

Think of Bluetooth (or SiK radio) replacing the USB cable. Note, on the F405 the battery must be connected to power the serial ports.

All the functions of the Ground station e.g. Mission Planner or QGC, work as normal including changing parameters, calibration, plus all the usual flight data.

You should be able to use the same idea with a tablet or laptop. For me I prefer to use QGC on the phone for quick edits especially in the field – although I do use MP on the laptop for initial setup.

Can you send me your full parameters? I tested and couldn’t reproduce, so I suspect a specific set of parameters is needed.

are you using 2 GPS here2 and a here ?

I agree, because 6 Modes over one channel are really weak.
But it has to be defined which channel has the priority (ModeChannel 1 to 6 or one of the
selected Mode by RCxxOption.)
e.g. already now in 4.0.0 Mode QStabilize in the FLTMode_CH and RTL in RCxxOption =4

Also a great idea, to use a lap top or tablet in the sun is not easy.

Why using another tool when a Transmitter has all needed when RCxxOption will be available, perhaps?
RCxxOption would be the better solution. One hit on a switch instead touching on a smart phone
through several menus.
I hope the solution with RCxxOption will come.


Thanks for all your improvements. I’m using Pixhawk 1. I updated the plane yesterday. I’ve had a great flight. But I have two problems. I could not connect with usb after the update. The safe key is not inactive without disarmed. When I’m armed, I press safe. Does not switch to Safe mode.

The most likely reason is incorrect USB drivers under windows. Please try these drivers:

that is the default now, and it was changed as we had a case where the safety switch activated while flying causing a crash.
You can change whether the safety switch works while armed using the BRD_SAFETYOPTION parameter