Pixracer with minimosd micro No data!

After doing some configuration with telemetry (frsky) everything is ok, except I’ve got a No Data displayed in my goggles. I’ve the latest firmware (3.5.4) .I connected my telemetry2 to the minimosd micro. Does someone has it working with a Pixracer? Thanks.

Haven’t tried that before. Anyway I have that setup using minim OSD micro.

Running OSD 2.2 on it with a Pixracer on telem 1.

When I plug the battery in the OSD is blank or stuck as it says nothing. I press the small boot button and it boots up just fine and my data is shown on the screen.

I plugged it into Telem 2 as you have it and on power on get nothing. I press the small boot button and it boots up just fine and my data is shown on the screen.

I know there other people running newer versions of the OSD code that don’t do what this firmware does such as request the telemeter data on boot up. It may also be sending heart beats to keep the data coming.

I do see on the OSD module the orange led blinking as the data is being received.


Did you enable telemetry 2 data ouput in the mission planner parameters ?

I have

is this what you mean?

Yes and also you have to set the data rate on this telemetry 2 port : the rate messages are sent from the vehicle can be controlled using the SRx_* parameters (i.e. SR2_POSITION).

I have a few FPV setups that exhibit the same non-startup action with the OSD.
These include standard Minim and Micro Minim with different firmware.

What I have found is seems related to the camera in that if I disconnect the video line from the camera to the OSD, only the video not the End, and reconnect, the OSD starts and operates normally.

This happens with the Sony CCD’s mostly.

I simply put a push button disconnect in the video line so that after boot, when having to push the PH safety switch. I also push the video switch to momentarily disconnect the camera and the OSD starts up.
So the OSD doesn’t reboot, it is already running, it just doesn’t seem to fire up the video encoder chip.

Hi, here’s my SR2 parameters, could you see somethig wrong? Thanks, Chris

Hi Mike, tried t disconnect and reconnect the yellow video wire from cam to OSD, but I can still see same displayed message No data!

I’ve installed MWOSD firmware now and applied these settings:
SERIAL2_BAUD, 57 (telemetry output at 57600)
SR2_EXT_STAT, 2 ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)
SR2_EXTRA1, 5 ( 5hz for attitude and simulation state)
SR2_EXTRA2, 2 ( 2hz for VFR_Hud data )
SR2_EXTRA3, 3 ( 3hz for AHRS, Hardware Status, Wind )
SR2_POSITION, 2 ( 2hz for location data )
SR2_RAW_SENS, 2 ( 2hz for raw imu sensor data )
SR2_RC_CHAN, 5 ( 5hz for radio input or radio output data )

but still no data.

Have you tried with TX and RX swapped?

thanks, yes I did, but still no data available

I’ve replaced my Minimosd micro with a new one, new wiring still the same problem… I’m wondering if Pixracer supports OSD via telem2…

I have Pixracer and I tried it on telem2 and it works just fine.


What I’ve seen this morning is RSSI is working. Does it mean there is a communication working between Telem2 and my osd? Do you firmware with MWOSD Chrome app? What option did you choose, MAVLINK or PX4 when you have to select the firmware? Is there something with MWOSD that I should change? Could you please tell me if you have the same SR2 parameters (see above) like me? If not could you share your parameters? One more info, I power my minimosd micro from the 2 pins (Ground +5V top of the pict), not from the controller, just the ground and rx and tx are connected. Am I wrong? Thanks for your precious time!

I have a mini MimimOSD module that I got from hobby king a while back. I made a cable for it so all I have to do is plug it in.

I am running the original software that came with the board which is OSD 2.2 that is very old.

Here is a picture of them. The bottom one is the one I use.

These board must be running a version that supports Mavlink to work.

MimimOSD Units


Wire connections:

JST GH connector: https://wiki.dronecode.org/workgroup/connectors/start

Pin1 power to Pin3 Power minimOSD
Pin2 Tx to Pin4 Rx minimOSD
Pin3 Rx to Pin5 Tx minimOSD
Pin4 CTS to Pin6 GRN minimOSD
Pin5 N/C
Pin6 Gnd to Pin2 minimOSD


I have this except pin1 not connected to FC because I power minimosd micro with external 5V power. But I let the ground connected to the FC. Is this wrong?

As long as there is a common ground you are good.


is it a way to check there is an output from my telem2? connecting direct tx rx to usb FTDI interface and to read values with arduino console?? I really understand because everything else is working. Frsky telemetry to taranis is ok, should just be a stupid lost parameter…

You could try one of these units. Sik Telemetry Radios

They come with the correct cables and you can use Mission Planner to see the data.

Mavlink data is binary data and is going to look like garbage on the screen.