Pixracer R15 Wi-Fi

I just purchased a new Pixracer from mRobotics, and I am unable to connect to the Wi-Fi. I called mRobotics and they were unable to provide an explanation. The SSID shows Ardupilot and I was told the password was pixracer, all lowercase. I tried with a windows Surface Pro 3 and my Samsung S8 Android phone, neither was able to connect. Any one with similar issues or even a work around?

Have you tried “ardupilot” as password?

1 Like

try “ardupilot” as a password instead.

If both of those fail update the firmware on the ESP8266. Not sure what Mro is putting on those radios but this is what you want.

This one-esp01_1m.bin

You need 1.1 minimum

Yes, you are right I pasted the wrong version. Fixed.

1 Like

That was it, you would think the support staff at mRobotics would know that.

1 Like

I did get connected with my PC, but was unable to get Mission Planner to communicate, I used UDP as the connection mode, but I was surprised it wanted a port. I went with the default 14550 with no luck. Tried a few other ports randomly with no luck.

I did get it to work on my Android phone, no port was necessary and QGroundControl simply connected. It did not however recognize the frame type and many other things. My guess it is a bit outdated.

Check your firewall :wink:

I did, I turned it off. Still no luck, but I was in the field. I will try again today when I have more time.

You have an alternative method to check if PC connect , as per WIKI:

  • connect from your PC to the wifi access point

  • open a browser to and a simple web interface will appear like below

I will try that as well, Thanks.

I would just connect with the USB cable for now unless you specifically need WiFi to do something. Most updates and everything I have heard about the WiFi connection makes it seem like it isn’t real reliable and causes issues.

The Wi-Fi came with my Pixracer and I was able to get it working. I am trying to avoid placing a telemetry radio on the copter.

Got it to work, it had the latest version of the firmware from the Wiki so I just changed the SSID and PWD noted the connection port, and off we go.



I gave up on my wifi - it works but it’s so unreliable that not worth the bother. I suspect this is something to do with the FC being inside a CF frame, but I evetually switched back to BT - lower tech, lower speed but far more reliable.

1 Like

If you move the wifi module outside the frame with a cable?

It’s possible, but on a small frame that’s a lot of hassle since I need to resolder the connector on the daughterboard and create a custom connector.