Servers by jDrones

Pixhawk4 Motor-Issue


(Collin01) #1

Hello,

I have Setup a holibro Pixhawk4 with arducopter Firmware.

I can configure the copter with Mission-planner.

But I have no pwm-signals at the ESCs

I can start the motor-test, but the ESCs don’t get any pwm Signal.

I use this Firmware:
ArduCopter V3.6.5-rc1 (d8752f0c)
ChibiOS: d2030d88
fmuv5 0037001E 3038510A 35323635

I have also testet with 3.7.0 and some other 3.6. Allways the some issue.

I hope for some help.

Regards.

Torsten


(Mike Boland) #2

How have you connected your PH4 to the motors?
The PH4 provides seperate outputs for the I/O PWM Output and the FMU PWM Output.
You need to use the I/O PWM Output.
Also note that PH4 uses 3.3v PWM signals, so be sure your ESC’s will operate at that voltage.


(James Pattison) #3

Update your firmware to this one: http://firmware.ardupilot.org/Copter/stable/Pixhawk4/ by downloading the .apj and then load from file in Missionplanner. It would be a good idea to then update the bootloader so Missionplanner can identify the board correctly in the future.
As Mike suggests, check which outputs your motors are connected to on the power board, and which ones you’ve got connected between the PH4 and power board. A photo and your parameter file would be useful.


(Collin01) #4

OK, Thank you. This solve my problem.
In my understanding, I had assumed that the ESC will be connected to the FMU.
Everything works fine on the I / O PWM.


(James Pattison) #5

If you want to use DShot, they need to be on FMU pins, but you can do that by connecting the IO socket on the PDB to the FMU outputs on the flight controller.