Servers by jDrones

Pixhawk4 Mini (holybro) failed to update IO fw

Unable to install ArduCopter on new Pixhawk 4 Mini.
Tried 2 boards just to make sure. Help :smile:

Check BRD_TYPE: Failed to update IO firmware
Initialising APM
Frame: UNKNOWN
fmuv5 0030002B 32375118 32363435
ChibiOS: ff603d11
ArduCopter V3.6.4 (6c4da9e3)
Check BRD_TYPE: Failed to update IO firmware

That’s probably Missionplanner?
The bootloader that ships with the PH4-mini doesn’t differentiate it from the PH4, so the way Missionplanner decides which firmware to load doesn’t work properly.
If you update to the ArduPilot bootloader for it, it’ll select the right firmware. Or you can use the custom firmware option.
FYI for Copter, PH4-Mini isn’t on a Stable release.
http://firmware.ardupilot.org/Copter/beta/PH4-mini/

1 Like

Hey, thank you so much!

How about this one?
http://firmware.ardupilot.org/Copter/stable/PH4-mini/

No worries.
I quite like the PH4-Mini.
To see one in flight with ArduPilot, the mini-quad in this video: https://youtu.be/0s1ZBSB0tvM has one (no production on that vid, it’s just a flight record, but pretty cool nonetheless).

Brain fade on my part. Good find.
Rover/PH4-Mini is still in beta though.

I had the same problem with my PH4 mini, i downloaded the same file for plane, and custom installed, and it now works well but no beeps on start up? is it suppose to beep on start up?

Hi all~
i use the firmware is OK.
http://firmware.ardupilot.org/Copter/stable/PH4-mini/

but i build APM Copter3.6.9 to pixhawk 4 mini.
./waf configure --board fmuv5
./waf copter

Check BRD_TYPE: Failed to update IO firmware
Initialising APM
Frame: QUAD
fmuv5 00440020 31385119 35343633
ChibiOS: d2030d88
ArduCopter V3.6.9 (632be63f)
Check BRD_TYPE: Failed to update IO firmware

Does anyone know of it ? thanks~

Try ./waf configure —board PH4-mini

i got it~ thank you!

I am still experiencing same error message despite following all of the above ideas. Tried MP and QGC for ArduCopter.

Make sure you have PH4-mini firmware (not fmuv5), then try updating the bootloader (ctrl-F in Missionplanner then click the button). Then reboot.

Servers by jDrones