Pixhawk2 mainout powering from esc(flame 200a hv)

FC : PIXHAWK2, v3.6.7
ESC : FLAME 200A HV, LINK : https://store-en.tmotor.com/goods.php?id=918
MOTOR : U15II KV100 * 6

This ESC has power line with signal line.

And I couldn’t find nobody use this ESC.

Other FLAME ESCs have no power line with signal line. KDE ESC has power line and they have manual.

Does anybody know about this?

Thank you!

Definitely update to latest stable release, AC 4.0.5 (at this time)

I’m not impressed by the almost complete lack of details in the manual (1 page) or any diagrams. I think those Flame ESCs have two lots of wires to servo connectors.
The one with three wires is for programming, and the one you want with two wires is the PWM input.
Search and read through the posts about large props, like 28inch and similar - I assume you’re using big props of you have 200A ESCs. Gather all the knowledge you can…

You will need these settings, and don’t worry about trying to calibrate the ESCs even though the manual says to do so.
MOT_THST_EXPO,0.2
MOT_PWM_MIN,1100
MOT_PWM_MAX,1940
ATC_INPUT_TC,0.2 <- optional

Both wires are 3 line unlike other T-MOTOR FLAME ESCs. (Programming and PWM input)

If there is no power in mainout, ESC doesn’t work

When giviving 5v(from bec) to mainout, It works.

I will refer to your parameters and Version.

Thank you a lot Shawn.

Hi Haesolkim

Could you help me I’m using
ESC flame 200a HV
U15II KV100
Flight control pixhawk cube orange

I am not able to use my motor with this ESC I tried few solutions but it isn’t working could you tell me what steps you took while the connections

You need to supply 5V to the ESC to make it work.
T-Motor should mention it somewhere, but looks like they are too lazy to make good manuals.

1 Like

Hi Mallikarjun,
I tried my cube black pixhawk while providing 5V supply to the ESC(flame 200a) externally but still it is not working could you share the circuit diagram of your setup or might help.me with this problem??

Share a picture of setup!

If you.have picture of your setup could you send here

If you are asking me that would take some time, I will try to send it today

No picture, no solution!
I don’t have one handy!

Would you please help me with what you tried to run the motors with Flame 200a with cube black or cube orange

I tried to run the motor with Pixhawk 2.4.8 the ESCs are working fine