Pixhawk Yaw on takeoff

I have just finished a pixhawk quad build but when i try to takeoff it is very unstable and yaws clockwise.
my build specs are
Frame F450
motor E-Max 2213 935kv
props 1045
transmitter Fly-Sky Fs-i6x
esc blheli_s 35 amps one-shot 125
battery 3s lipo 3300 mah

this is my .BIN file can any one please help me.
00000001.BIN (1014.4 KB)

i have calibrated the esc and motors many time i have tried adjusting the cog (center of gravity)
i have tried trimming on the transmitter and re uploading the mission planner software and nothing has worked so far.

Hello @Srihith

I can not see much in your log because you LOG_BITMASK was not sufficient to see, try to select these bit before the next tests

According to your log, there is something I can point out:

The battery, power supply system seems to be odd. As you can see at the photo below: Voltage dropped so hard and current got very high, right after this moment, the voltage supply for IMU/FMU - your autopilot was dropped to 4.5V - this is not good because 4.5V is not simply enough. Whichever autopilots you use, I suggest it should be 5V - 5.2V. Battery voltage dropped is inevitable but it dropped to 2V is not acceptable.

Please check the battery to make sure you have your power supply is “healthy” enough

About the flight mode, you must not fly in Loiter at the very first time. Please try to follow the Tunning Guidance here: Tuning Process Instructions — Copter documentation

About the propellers and motor rotating direction, please make sure you are right at this point. I assume you are using Quad X and motor direction should be configued as follow. A photo of the drone from you may help a lot.

Good luck!

Thank you for the response.
I will have a look at the battery and even when i start in stabilise mode it still is uncontrollable.
i have checked the motor direction many times and nothing seems to be wrong.
i have added the pictures below.

I have an extra question.I am very new to the drone hobby and i do not know how to access the LOG_BITMASK. I am using mission planner 4.1.2.

In the top bar, there is “CONFIG” → “Full Parameter list” → Search for this parameter, change it → “Write Params” in the right side.


The motor ESC connecting to your autopilot is not clear to me. However I assume you are setting this motor order and heading of the drone like photo below?

If so, it should be wrong and the correct one is below:

You can try to test the motor by following this Wiki - testing by Motor test function in Mission Planner:

Remember to remove the props and:
Motor A = 1
Motor B = 4
Motor C = 2
Motor D = 3

Next time, you will want to video your test for easier diagnosing.
Good luck,

WP_NAV_MIN_ALT is probably relevant for you

I have changed the motor config and the battery, but still very unstable when attempt to take off.
I have linked the video of an attempted takeoff.

Also I have attached the screenshot of Auto LogAnalysis of log file in this link

I deleted the existing log in the SD card (00000001.BIN) and after next attempted take off there was no new log files created.

Where is your heading of the drone, is it between 2 white arms? If so, you are mounting propellers wrongly so the rotating of the motors are also wrong. Please have some time to make sure where is your motor 1, 2, 3 and 4. Motor 1 and 2: CCW; Motor 3 and 4: CW.

This photo seems to be the right propellers mounting, you just need to change/check the motor orders


That’s what many say and it’s usually still the problem.Either because they didn’t run Motor Test in Mission Planner or didn’t understand how the test is run.

I have ran the motor test multiple times and double checked motor placement and nothing seems to be wrong

Through the video you send above: motors direction and propellers might not be right. Can you record the video of your motor testing process?

I have recorded the motor test and have posted a link to it below. Correct me if any of my motors are spinning the opposite way.
i Have also added and image of the drone down below.

If you check my post #6 clearly you can figure out yourself. Pixhawk Yaw on takeoff - #6 by bigboy061293

As I stated. In MP:
Motor A is Motor 1
Motor B is Motor 4
Motor C is Motor 2
Motor D is Motor 3

By looking at your photo and video I am confidently saying you was wrong at this step and please recheck it.

Why don’t you simply follow the link on the Motor Test Page, where it says “please click here”, and read the Wiki. You have it wrong.

Order, direction and Motor Test sequence is all shown on the Wiki page. Here it is:

Hi Vu,
Sorry, in the picture I have numbered the motors in the order they spin during Motor Test.
The connection of Motors to the Pixhawk is exactly in the same order you have mentioned.
I have sent the correct order below.

Now change the motor direction as @dkemxr and I mentioned in the previous posts.

I have done as you said. Here is the current motor direction, confirmed after motor test.

Whats next? can I now try flying it?

Probably not. Did you set the Initial Tuning parameters? Read this and use the Initial Parameter Setup Page in Mission Planner. Setup>Mandatory Hardware>Initial Parameter Setup.

This one:

If you read the Wiki you would know this:

I am using the same version of MP as you but i do not get the Initial Parameter Settings opting Under Mandatory Hardware.