PixHawk with DJI E310...help!?

So, this is my first build…ever. A friend gave me an “old” F450. I kept the E310 ESCs and 2312 motors and I’ve replaced everything naza with a PixHawk FC, a PH compatible GPS, telemetry radios, etc. I’ve wired everything up and gone through the Mission Planner Setup wizard, but couldn’t get any response from the motors. Accel, Compass, and Radio calibrations all “passed”. GPS and ADI in MP both work. Now, I can arm but nothing happens with the motors. PH LED changes from flashing green to solid green and MP shows “arm”. Safety switch is installed and safety disengaged. I have the two power wires soldered to the board and the three wire outputs going to the PH Main Out 1-4. My Spektrum DSMX receiver inputs to the PH SPKT/DSM port.
Any ideas on what I might be doing wrong?

Have you tried the motor test. Since these are DJI motors they don’t startup until the PWM gets to 1000.


I have and the motors don’t spin. The PixHawk flashes red/green/blue accompanied by a tone for 1-2 seconds, then a positive sounding tone to end it. No indication in Mission Planner of errors.
My radios are calibrated to 1078-1920. I altered throttle to just below 998-1920, no change in results.

Range 1120-1920

use MOT_PWM_MIN and MOT_PWM_MAX to set the values which makes it independent of the CH3 range

How do you change that in mission planner? I went to parameters and couldn’t find anything starting with MOT.

On the planner tab where it says Layout make sure it says Advanced in the pull down. Then you will have some additional options to see all the parameters.


Changed the values, no luck. Still the same issue. Any other ideas? Really want this to work.

We’re going to need a picture of how you have this plugged into the ESC’s. This should work.

Maybe you could hook channel Three from the spectrum receiver to one of the ESC’s and see if it spins that way.

That would take the Pixhawk out of the equation.


Each ESC is plugged into the corresponding Main Out port and the black (+/-) power is soldered to the board.

This is my receiver. It only has three wires and plugs into the SPKT/DSM port. Would I connect one of these three wires (CH3?) to the Yellow PWM wire for the ESC? (As well as 5V & Gnd)

I don’t know anything about DSMX receiver… Where are you powering the ESC’s from. The main rail is not powered.


My understanding was that the black wire seen under the arm is power, 11-12V & GND (didn’t mean to say 5V earlier). The battey supplies this power. The ESC cable plugged into the PixHawk is the control signal (yellow), GND (brown), and an unused wire (red).
I also have an AR6210 rcvr, should I be using this?

The ESCs need two things to function, power and signal…

Signal looks good, everything is in the proper ports and orientations and the Pixhawk sounds like it’s arming properly. You could try plugging one of the ESCs into the throttle channel of the AR6210 to bypass the Pixhawk, but you’ll have to use an extra 5V source to power the Rx as the ESC won’t provide it power. So the ESC powered by the flight battery and the AR6210 powered by another source (battery or BEC). And I always cycle the throttle fully both ways (slowly) if the ESC doesn’t seem to be starting just in case the throttle channel is reversed.

Do the motors all beep when you connect power? Did you check with a voltmeter the power to the ESC wires after plugging in the battery?

That Spektrum 2.4 receiver is a bit too close for comfort to the telemetry radio. You might get away with it, but I’d try for a few more inches of separation. At least the lower antenna is in a good place.

Thanks for the help. I found my biggest problem: power board was broken and I was only checking voltage at the battery connection (it wasn’t making it to the ESCs). Now they all power up, but rapidly flash yellow when safety switch is disabled (“throttle not at bottom” error). I’m playing with radio and motor PWM values. No luck yet. If I can’t get it to work then I might just swap out the ESCs. Would I need to replace motors as well (using DJI 2312s)? I would expect motors to be compatible with any ESC, but I also expected ESCs to be compatible with any flight controller.

After you sort out the Power of the ESC’s start from the beginning.

Just do a normal radio calibration.

Set the MOT_PWM_MIN and MOT_PWM_MAX to 1120 /1920


Now when you power the drone you might get something like this

beeping while safety switch off (yellow leds) - this can be changed later

Luisvale, I’m jealous. That looks awesome. I’m still playing around with parameters before I break down and buy some non-dji esc/motors. Hopefully I can stumble across a successful configuration.

Just wanted to update. I got the motors to spin today by setting the MOT_PWM_MIN to 900. Motors don’t spin at the same RPM, so I’m going to tweak the values and I can post some final values when I’m done. Hopefully someone else might be able to use them to get their E310s working.