Pixhawk servo gimbal did not stabilise roll and pitch

I am using Pixhawk with rc servo gimbal. I checked my servo motors in gimbal which worked fine. I have given 5v in pixhawk serv rail to power servo motor. when I change servo angle and servo limit, the gimbal moves as per the input. but when pitch or roll my quad the gimbal did not stabilize. I am sure I have set the MNT_STAB_ROLL and MNT_STAB_TILT to 1.
I have flew this setup last month with no change. Is it a hardware issue?

I have attached param file…

@rmackay9 pls give your input 4.log.param (8.5 KB)

I just had the exact same issue with my Pixhawk, FW V4.0.7. I tried moving to a different port, use a different servo, but it won’t respond to drone attitude changes, only to servo parameter changes (min/max PWM et angle limits). The only different thing I did since the last time was to connect with QGC on my phone rather than MP on my laptop. I tried reverting to the laptop, but no servo stabilisation.

1 Like

Finally figured it out. Looks like this parameter got changed, and needed to be set to:
MNT_DEFLT_MODE : 3 (RC Targeting). It was previously set to 0 (Neutral).

1 Like