Pixhawk PX4 Flysky FS-I6X Arducopter 4.0.1 motor running on switch error

Me again, another chapter in the Flysky saga, Thanks again in advance for any help. Using Qgroundcontrol (new version) arducopter heli 4.0.5 with chibios, Pixhawk PX4, Flysky Fs-I6X with Flysky FS-IA6B receiver(does 8 channels in PPM mode) and transmitter in airplane mode or heli fixed pitch ( same results in either mode). Using throttle curve or Rc passthrough same results, I have set a on/off switch in radio for channel 8 to go from low to high pwm rate, calibrated accel and compass, Pixhawk arms OK with channel 8 switch on low pwm, servos work as they should, nothing tuned yet, calibrated motor to radio through receiver beforehand, ch 3 pwm rate is 1000 to 1985Pixhawk parmeters copter 4.0.5 1-1-21.txt (28.5 KB) . Problem is when armed with throttle down position, flip channel 8 switch off and motor runs with no throttle input (moving throttle up/down will slow or speed motor somewhat very little response) cannot stop motor with throttle low, only ch 8 switch stops motor or disarm? Also in Qgroundcontrol motor test does not engage, motor does not run at all? The motor will only run when armed and ch 8 switch is off, but at a mid type rpm, does not matter whether throttle is up or down? I tried to upload parameter list, hope it works? Thanks again

@rfine7666 William,
I looked at your param file and it doesn’t appear that you have set up the collective or trimmed the swashplate? Are you following the set up wiki? This also describes the different RSC modes and how they are intended to work.

This sounds like it is working as designed. When you say “throttle” up or down, I think you mean the throttle stick on the transmitter, which actually controls collective. It is only because you are using the throttle curve RSC mode that the throttle (collective) stick position affects the engine throttle. Looking at your throttle curve in the param file, the collective at full down is still 25% throttle out.

I would not use the motor test in MP or QGC. I think it is best to test it like your are with the blades removed.

If you haven’t done so, please use the wiki set up procedures or if you need help with the set up procedures, let me know.


thanks again for you help. I do not have collective or swashplate set or trimmed yet, trying to cure motor throttle curve problem first. I do not have a governor on my ESC, but I get the same results in throttle curve mode or rc passthrough mode? Not understanding the statement (the collective at full down is still 25% throttle out) is this something I can change in full parameters or is this a transmitter problem? I have noticed in QGC or MP transmitter setup if I do not set a switch to lower ch 8 pwm that the ch 8 pwm rate is showing around 25% or so, do not know why?
Is not RSC setpoint only for ESC with governor?
Sorry to be a pain, but I do not know what I am doing wrong? Thanks again, you and Chris always a big help.

Where do I look in full parameter list to find ((the collective at full down is still 25% throttle out) Thanks

Throttle curve is a 5 point curve set with the following Params

You can find this on the heli page in QGC or MP in addition to the full parameter list in MP

This curve is based on the collective where H_RSC_THRCRV_0 Is the throttle setting for the H_COL_MIN and H_RSC_THRCRV_100 is the throttle setting for H_COL_MAX. So even though you have collective at the min value doesn’t mean that throttle should be zero. The throttle should be at a value that keeps the rotor spinning at the desired rotor speed. Then the rest of the curve is set to maintain a constant speed as the collective loads the rotor. The motor interlock (ch 8) is designed to turn on/off the motor. You will not need to set H_RSC_IDLE. That is used for combustion engines.
Check out this post. It may help explain the throttle curve and how it works.

thanks again, I will try your suggestions, no one locally flying helicopters or using Pixhawk for helicopter

Thanks Bill
Problem was H-RSC_THRCRV_0 was set to 25%, I set to 0%, , working as it should now, motor stops now.
Question in arducopter heli firmware 4.0.5 is there a parameter I have to lower for ALT-HOLD like PSC_ACCZ-P or ACCELZ-P , so as alt-hold does not jump up and down as in previous versions?
Thanks again

Again, that is not how it is designed to work. The motor interlock (ch8) is used like the throttle hold used for a heli that doesn’t use an autopilot system. Even without an autopilot, I don’t know if throttle curves for electric systems would be set for 0 throttle output with collective all the way down. But I guess if the collective is such that it is in autorotation then that would be ok.
From what I understand of setting throttle curves for electric power systems, it will probably be pretty flat. The default throttle curve is set up for an internal combustion engine.

Thanks Bill I will try it as you recommend for now I am happy I got motor to work I did not know why it would not shut off still learning

Hello I am very new and I want to put my Flysky Fs-I6X to work with me Pixhawk PX4 can you help me. Thank You

@AC6RB George,
Welcome! I think the best way to do this is for you to invest some time reading thru the traditional helicopter wiki to learn about how to set up a heli with a flight controller. If you have question, don’t hesitate to start you own topic on this website under traditional helicopter and we can help you. Hopefully the wiki will help you with most of the setup.