PixHawk PX4 firmware

I have a Pixhawk PX4 Autopilot PIX 2.4.8 I am using on a hexcopter. I haven’t flown it for years, forgot what was wring with it. I found out today. It flipped over as soon as it took off. I decided to start from scratch and install the firmware again and go through the entire setup.

It looks for a file called ArduCopter-v2.px4 in the Stable folder, which doesn’t exist. I have downloaded 4 different versions of hexcopter firmware and tried installing them using the CUSTOM button, but it doesn’t work.

Could someone please point me in the right direction?

Thank you very much

Use the Pixhawk1 firmware
It should easily flash from either Mission Planner or QGC

I downloaded and installed QGC. It easily installed firmware with no options given to me. It installed px4fmu-v2_default.px4

Now it makes the familiar sounds when it boots up. I don’t see how to do much of anything with QGC, though.

With APMPlanner, choosing Initial Setup only shows the firmware installation page, but I can’t do anything with it. This happens whether the flight controller is connected or not. It seems to connect when I try, it gives no error messages and shows “DISARMED”, but no other indication that it is connected.

Sure there are options. Select these:

I tried that, the ChibiOS using various board types: CubePurple, Pixhawk 1 1M, Pixhawk 1 1M BDShot, Pixhawk 1, fmuv2, fmuv3. All showed “QGC does not currently support setup of your vehicle type”. I did not try CubeSolo, CubeBlack, Skyviper_Journey, Skyviper - 2450, CubeGreen Solo or mro v2.1

I tried using PXHwk Pro Stable Release v1.13.0 using the top pulldown menu. That seemed to work. I was able to calibrate the compass, accelerometer, set the flight modes. It is when I got to the power settings that things went wrong.

It said two lines were missing - 1:BAT_A_PER_V and 1:BAT_V_DIV

When I try to calibrate the ESCs, it says to unplug the battery first, even though no battery is connected.

Trying to test the motors works

Hooking it up to APM Planner 2.0, it only has the Firmware installation page showing. Trying to install a firmware, it says “No valid device found” and says to make sure the flight controller is plugged in and the drivers have been installed. I do this with the FC not being connected, although it DOES connect if I try. The only thing that changed on the screen is that STATUS changes to UNARMED

I’m also not sure I have the motors set right. Going clockwise from the front, they are 5,1,4,6,2 and 3… That doesn’t sound right, but haven’t found the documentation on that yet.

Trying to arm it and start the motors as if taking off does not work. The motors don’t start

I really appreciate your help and am sorry I am being such a bother.

It sounds like you’ve loaded the PX4 firmware, if that’s what you desire then head over to the PX4 forums for support

Otherwise that flight controller will need the latest stable Ardupilot firmware for Pixhawk1

I doubt that APM Planner will help you out much, I think it’s out of date - it could be OK for modifying parameters after the firmware install, but QGC will be better and it is actively supported.

After trying four computers, I finally got the right firmware installed (the one you suggested).
Everything is familiar now.

Thank you again for your help!

Be sure to do the Initial Parameters after the voltage monitor setup and all the other mandatory items.
Let us know if you need help, but generally everything is in the docs or searchable on here.

MissionPlanner motor test! Avoid the flip-overs :slight_smile:

It flies, it flies, it flies! First time in 3 or 4 years. I just got it to hover in place, it is really windy today. I will take it the the flight field as soon as possible to give it a real workout

Good to hear!
If you can give us a link to a .bin log file we can help with a bit of fine tuning too.
Or if you prefer we can point out some things for your research and you can do them yourself, since you have experience.
That hover flight is ideal to look at before you head out to the field.