Pixhawk PC connection error

I bought a new pixhawk and I can’t connect it to my computer. No USB connection sound. What is the solution? Blue light is flashing.When I energize the pixhawk by pressing the button, the B/E led flashes.

The USB cable is solid. I tried inserting an empty memory card. I tried without inserting a memory card.The PC does not see the hardware.

Did you check the drivers installed with MP

1 Like

Which driver should I install? PC doesn’t see Pixhawk at all.

What is the name of the driver?

I think I once found the driver in the “Drivers” folder of the folder to which Mission Planner was installed. So typically “C:\Program Files (x86)\Mission Planner\Drivers”, maybe you can give that a try…

1 Like

The same problem continues. PC doesn’t see Pixhawk.

Pixhawk is getting power from USB but not receiving data. The cable can carry data.:expressionless:

Have you checked with Windows “Device Manager”, if you plug the USB cable (connected to the Pixhawk) in or out then typically it will refresh and show if a new device was connected. Its normally under the “Ports (COM & LPT)” group.

1 Like

yes. there is no pixhawk in device manager.

Yes, I tried. Pixhawk doesn’t show up in device manager.

try qgroundcontrol and check if your fc its recognized by the system.
Please don’t post double topics.

1 Like

Qgroundcontrol I’ve triedI’ve tried The problem was not fixed.PC doesn’t see pixhawk in device manager.

Why can’t I get a clear answer :expressionless:

Do you have a power brick? maybe you could try to powering it separately so that it does not take any power from the PC and then see if it gets detected.

This is not the normal behaviour for these Pixhawks, so something must be strange in your case. Maybe you have a faulty unit. Have you tried on a different computer?

1 Like

Sounds similar?

Sounds like he could get it kind of working with a separate supply…

Have you tried a different cable. I have had issues with Cables not working on the Pixhawk. While it powers it, it won’t transfer data. So I replaced the USB cable.


I tried it on 3 separate USB cables. Cables are solid. Connection failed.I tried to feed the Pixhawk with the Power module and connect it via USB. The result is unsuccessful.

I suspect the Pixhawk’s 3.3 volt IC is faulty. What do you think will happen if I supply 3.3volts from the ABC 3.3V socket on the reverse?What do you think will happen if I supply 3.3volts from the ABC 3.3V socket on the reverse?:sweat_smile::sweat_smile::sweat_smile:🤷

You mean on the ADC pins? Sounds a bit risky to me, as far as I know they go to the MCU. Maybe you can first measure the voltage on the SPKT/DSM pins. Looks like they should give 3.3V and I suppose if you measure 3.3V there then the regulator is fine.

1 Like