Pixhawk not working with power module

Recently I bought a pixhawk 2.4.7 FC and tried powering it on using the power module. But as soon as I connect the power module, it gets hot and the FC doesn’t power up. I also checked the voltage of power module. It has 5.1v. Also I tried replaing the power module, but FC didn’t power up. Kindly help me to solve the issue. I think there is a problem with the FC.
Thank you!

Does the flight controller work plugged in only USB to a laptop/computer? No power module.

Yes. Works only with usb connection. Not with power module.

well pixhawk have three redundant lines.
As ive understood your fc get hot when you are connecting the power module,
If the voltage regulator of your fc is already damage, you cannot do nothing… aside try repair it and use it on a rover.

It’s the power module getting hot not the FC?

I think that your power module is damage.
what kind of power module are you using

The power module is working fine. I’ve also tried replacing the old power module with new one.

Both the power module and fc are getting hot.

Nothing gets hot when you use USB only?

Yes, with usb everything is working fine.

I would agree with the Dave’s that you have a power module problem. Only other possibility is that you have something connected to the ouputs and the onboard diode is shorted causing the outboard devices to draw power from the power module, which the diode is designed to prevent. Any servo’s or such connect to the output ports?

do you mind attach pls the power module are you using now

Check out the wiring, if you bought a cheap Chinese knock-off power module, there is a good chance that is wired reverse.
Measure output pins on the power module…

Smoke 'Em If You Got 'Em

Uploading: IMG_20210120_224147.jpg…
I’m using this module.

I’ve checked the voltage. The module is working fine

As you are saying, if the module work properly there is no reasons for become hot and make hot also the fc.
With a full 12v battery charge the Vout must be 5.32V

Yes the voltage is 5.2 v. But I don’t know why it is not orking with the FC.

check the correct pinout.
your power module is s clone of the 3dr?
Image you attach doesn’t work

A 2.4.7, is a Chinese knock off, any “Pixhawk” that has the 3rd digit, in this case a 7, is a knock off. I learned this at a meeting with the “Cube” team of engineers on a video conference call with engineers from Australia and China. Just for your info. The best way to be sure you get an official Pixhawk, the controller will indicate just the 2.4. Better yet, buy a Cube system then you will get full support from the company. The US distributor is IRLock.