Pixhawk not port


I’ve worked with many different Pixhawks but this is the first time I’ve encountered something like this. I’ve used this Pixhawk in the past. I haven’t used it for about 6 months. I tried to connect today. However, the computer did not see the Pixhawk. In other words, when I looked through Mission Planner, no ports were opened. I tried pressing the buttons on either side of the Pixhawk but no difference.

I also used the power module, when I powered it with the power module, the Receiver and the like seemed to be connected. I also tried to connect via telemetry, but still couldn’t connect. I also reset the micro SD card but no change.

When I connect it, there is no action on the middle led. PWR and B/E leds are constantly on. The ACT led is flashing.

What path should I follow? Thanks a lot.

still i have this problem, anyone have solve?

Have you tried a different USB cable, it could be possible this one is only power and not data. also if you have the ability try a different usb port or even a different laptop. Might want to make sure all the drivers are installed. Maybe uninstall Mission planner and reinstall that way you get all the current stuff. When you plug it in to the PC do you hear that common USB plugged in sound if not I bet that cable is for power only

I’ve tried both with different computers and different cables. I tried your other suggestions as well, no difference unfortunately.