Servers by jDrones

Pixhawk no log files or folder

My Pixhawk is not writing log files. The SD card has the Terrain folder but no Log folder. I’ve tried a new SD card and have the same problem.

Am I missing something really simple here? I can’t find any obvious Turn Logs On option.

Thanks

I think DataFlash logging doesn’t start until the plane is armed. Are you arming it?

There is also a parameter you can set which begins logging at boot, but this is off by default because logs would get very long with not-interesting details. But if you can’t arm for some reason, this would let you test if there’s still a log-creation problem.

1 Like

Yes, plane armed and sent on Auto flight. No logs at all on SD card.
I’ve tried with logging at boot on and off but no difference.
Is there a basic way to enable or disable logging that I’ve missed?

Strange. I don’t know any way you could disable logging without modifying the firmware. Perhaps you could try re-flashing the firmware?

Or maybe someone else on these forums knows something that I don’t?

[45.png]
anparkinson
November 3

Yes, plane armed and sent on Auto flight. No logs at all on SD card.
I’ve tried with logging at boot on and off but no difference.
Is there a basic way to enable or disable logging that I’ve missed?

No, it shoul dlog out-of-the-box.

Setting the parameter LOG_DISARMED should cause it to log all of the time.

Setting the parameter LOF_FILE_DSRMROT should close the current log file
each time you disarm ('though if you are not logging while disarmed it
will only be created when you next arm).

So. To your problem.

Is your LOG_BITMASK non-zero?

Is your LOG_BACKEND_TYPE 1 or 3?

LOG_BITMASK set to 65535which is Pixhawk default
LOG_BACKEND_TYPE set to 2. I’ll change to 3.
Why would it be on 2?
Thanks

LOG_BITMASK set to 65535which is Pixhawk default
LOG_BACKEND_TYPE set to 2. I’ll change to 3.
Why would it be on 2?

That I can’t say. It’s certainly not the default!

Peter

Update - now getting log files after changing LOG_BACKEND_TYPE to 3. Thanks Peter.

BUT - cannot download by Mavlink either wireless or with cable. I get the error message in rhe link below. It means I Have to remove the SD card and put it in my laptop to get the log files.

Is there a solution to this?

(http://www.medifarm.co.uk/log_files.png)

BUT - cannot download by Mavlink either wireless or with cable. I get the
error message in rhe link below. It means I Have to remove the SD card and
put it in my laptop to get the log files.

Is there a solution to this?

(http://www.medifarm.co.uk/log_files.png)

Disarm your vehicle?

hello , I wont the log with the disarming ; how can we do it?

I know I’m just a few years late to this convo, but I think I’m having a similar problem. How exactly can I set the parameter which begins logging at boot? Can I do that on Mission Planner, cuz I can’t find anything in Mission Planner for that?

LOG_DISARMED: Enable logging while disarmed

If LOG_DISARMED is set to 1 then logging will be enabled while disarmed. This can make for very large logfiles but can help a lot when tracking down startup issues

Values
Value Meaning


0 Disabled
1 Enabled

I found the LOG_DISARMED command in the Full Parameter List under CONFIG in Mission Planner. I clicked the checkmark next to it, but I’m not sure how to actually change the value to 1. Any idea how to do that? (It’s probably a simple fix but I’m not very familiar with Mission Planner)
Thanks!

I beleive thats all you needed to do but you need to press write params on the upper right side of MP to save that parameter.
The other option is to make a text file on your pc with
LOG_DISARMED,1
in the file
Then go to the advanced param listing and load from file. Pick the next text file remember it’s a text file so you need to tell the open file dialog box that your looking for a text file and not a param file…or change the extension on your text file to .param.
Either way load from file then click write.
This is the method I use for all config changes. I have a file on my pc that I use to upload any param changes I need.
anyway just a thought

The Write Params option worked perfectly and I was able to save the LOG_DISARMED parameter to 1. Then I made sure the pixhawk was connected properly and gave it a little shake…for about 30 seconds.
But when I opened File Explorer and navigated to the local Mission Planner > logs > Quadrotor > 1 location where everything should be saved, I couldn’t find any new .BIN or .ULOG datalog files. Instead, all I saw was a 2 new files: an RLOG and a Telemetry Log. I was already getting these two on every time I connected my pixhawk prior to making the parameter changes.
In summary: while the LOG_DISARMED parameter has now been changed to 1, I can’t seem to find the actual data logs after a short test run. Any idea why? Thanks again!

Did you try to down load the log from teh flight controller.
The logs are not written to mission planner. They are stored locally on the FC and you need to go get them.
https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

Yes, I tried that. I also used a few different SD-cards but that didn’t change anything. But turns out that the Telemetry Logs also have vibration data, so I just decided to use that instead.
I appreciate your help!

These are not of much value, the sample rate is too low. You need dataflash logs to advance. So you are saying that after arming the craft and then disarming there is not a log on the Sd card (take it out and look at it directly) in the LOGS directory? Is there a LOGS directory?

For the sake of my project, the sample rate (2 per second) is good enough. But I guess there’s no harm in making it better!
So what’s happening is that I switched the LOG_DISARMED parameter from 0 to 1 so I don’t have to arm the Pixhawk (I don’t want to arm it for my vibration test). Then I clicked “Write Parameters” to save it. After I connect the Pixhawk and run a quick vibration test (I see the vibration values in Mission Planner, so the Mavlink connection is fine) then disconnect it and open the SD-card on my laptop, I see that it doesn’t contain any new dataflash logs. There is a LOGS directory, but only because the SD-card was used a long time ago so there are a couple logs from 1999…none from the trials I run.
I tried using different SD-cards as well, but that didn’t work either.

Post your parameter file.

Servers by jDrones