Pixhawk Motors Keep Shutting down

I don’t know if I am in the right place or not, This is my first post here, and my first experience with Pixhawk. I posted on another forum and was directed here. the following is my issue:

Have my frame up and ready for flight testing. I am using PIXHAWK 2.4.8. The only things external at the moment is GPS module. I ran the wizard in MP. I can get the system armed, motors will start, throttle up and down just fine, but no matter where my throttle sits, if I move the right stick the unit will shut the motors down within 5 seconds. if I do not move the right stick it will allow the motors to run as long as I want them to There is obviously no way I can fly the unit like this, and since this is my first PIX, I am at a loss as to what to look for or why its doing this. When I hooked up to MP, I updated that first, then went through wizard for the setup. I have assigned no other channels at this time ( I need to figure out gimbal and retract switches later). I can immediately re-arm the system and it will repeat the problem over and over.

I am running 4s battery,
Taranis TX
X8R RX using S-BUS
Tiger 3508 380Kv motors
ARRIS 30A ESC (Simon k)

AS stated, unit will arm and disarm as advertised, just cannot move the right stick without a shutdown of total system after about 5 seconds, no matter where my throttle stands or where I move the right stick. Props are off during this testing. Can anyone shed some light on what the hell I am doing wrong here? This is becoming very frustrating considering all the kudos about the PIXHAWK system.

And yes, I have googled everywhere to try and find this, with no solution.

Hello Tim,

What is the version of firmware you have flashed into controller? Do you have ESC calibration performed? In which flight mode does it happen?

IMHO first of all you need to check how channels are mapped and working using RC calibration page of MP

In case all channels are ok you can set LOG_BITMASK parameter to the value 131070, then reproduce problem with motor shutdown by right stick and then disarm. Then attach your log file here pls to make it possible to analyse your problem.


Yes, Radio is calibrated. You will have to forgive my ignorance on this, as like stated before, this is my very first time dealing with a Pixhawk. I do not know what version of firmware (how to access it), I got it from MP version 1.3.41 build 1.1.6110.312876 APM: Copter 3.3.3 . I do not know how to set a LOG_BITMASK. ESC Calibration was performed after the first time it shutdown on me. The only difference now is the motors will run very slow with throttle closed (down) when armed.I have some logs but do not know which one to send. they are : BIN_FILE, KMZ, Text document, JPG_FILE.

Again Please forgive my ignorance on this. Tim

You don’t need to apologise for being newbie, because it is ok. I believe any of us was a newbie at some moment. That’s exactly the reason why community is a great thing. Anyone can ask a question and to have a chance to have an answer. As you pointed it, version of your firmware is 3.3.3.

Could you pls to perform following steps:

  1. Connect your pixhawk to MissionPlanner
  2. Open “CONFIG/TUNING” window (icon on top menu)
  3. Open “Full Parameter List” page (left-side menu)
  4. Press “Refresh Params” button on the right side
  5. Wait until progress bar will finish and all parameters will be refreshed
  6. Find LOG_BITMASK parameter and change it value to 131070
  7. Press “Write Params” button
  8. Wait until parameter will be updated in pixhawk
  9. Press “DISCONNECT” icon at top-right side
  10. Disconnect battery

Then you need to connect battery, arm your copter and reproduce issue. Then disarm it pls and disconnect battery. Then you need to find most recent log file on SD card in your pixhawk and attach it here in your response. Log files are named like <log_number>.BIN

Hope it helps

7.BIN (1.6 MB)

I did exactly as you instructed. Now the Pix will not even arm! All I get is the tones for initialisation, then a blinking yellow (green) light. When I ppush the arm switcvh, it goes solid, I hear the ESC’s then 2 loud Hi/low tones. that s it. Nothing more. I pulled BIN log #7 ( the last one) and attached it here.

Also, just for info, now when hooked up to mission planner, big LED is solid red, There’s a smaller one that’s solid green, and across from that solid red, and blinking blue. If that makes sense.

What exactly do you mean as “now”? At which exact moment it refused to arm? After you changed LOG_BITMASK value? After you reproduced issue and it got captured in log file? After you removed sd card from pixhawk?

In case you have solid red LED check pls if you forgot to insert sd card back to pixhawk?

So far I can see in your log file it seems you have problem with pixhawk powering from power module. It should has Vcc voltage value from 5.0V to 5.2V. As you can see your actual Vcc is about 4.7V which is not enough:

What kind of power module you are using? You need to measure a voltage on Vcc line from power module to pixhawk by multimeter. It should be about 5.3V. Here is pixhawk power connector pinout:

It started acting wrong when I changed the value. I could never get the motors to spin to reproduce issue. OK, as for power, on your lower schematic, i have a BEC attached to it ( I needed it to run 6S,and used a 90A Attopilot board. For the 5V IN (2 leftmost wires) are connected to BEC. the others (sensor and Mains) are soldered to the Attopilot board.

Changing of LOG_BITMASK value definitely should not affect controller behaviour in this way. Are you sure you haven’t changed any other parameters? Don’t you have suddenly missed a steps 4 and 5 in my list?

Anyway it seems you need to check your 5V line from BEC with multimeter. It should deliver not less then 5.3V to pixhawk. And you need to measure it on pixhawk power connector.

No other changes made, went exactly by your instructions (which I will thank you very much, as the way you describe and write down makes it easy to understand). I will check wiring and replace UBEC then try everything again.

Ok, I’m back. Got new power supply for it. Still will not arm. All I get is the normal start up LEDs, then immediately get three tones, high, two low, then just blinks twice yellow, pause, twice yellow, pause, and so on. All I can get out of that is some kind of fail safe issue.


Do you have 5V line voltage measured for old and new PM/UBEC? What value are they have?

Try to disconnect battery, then disconnect all PWM and AUX outputs, then connect battery and then arm it again.
It would be nice to have logs from this attempt with LOG_BITMASK set to 131070.

Hello again and thank you for responding. I get the multi tone when I turn unit on, but then just flashes yellow. Cannot arm because it it saying “throttle below failsafe”. I don’t know if it will have log if it cannot arm. I did not have this issue before, just started after the replacement of the power supply lead. Again, I am very novice at this Pixhawk, used NAZA on all my other Copters.I did what you said above about removing all PWM outputs, nothing changed. Someday I would really like to get this beastie in the air!

Throttle below failsafe means no input from your RC Rx.
Is it powered?
Is it connected correctly?

In the radio calibration page are the bars moving when you move the sticks?

Yes, Radio (taranis) is on, x8r is green, I have calibrated the radio about 5 times already, and it comes out OK each time. Reboot, and right back to same place.Sitck move as advertised.

In your Failsafe Screen, what value have got against the throttle failsafe?

It needs to just below min throttle.

It says 937 on MP. I can change it but doesn’t make the LED change.

In your Failsafe screen you have Throttle Failsafe enabled I assume with a value of 937 from what you have said.

When you go to the radio calibration page what is the value of you throttle channel?
Do all the bars move when you move the sticks?

A quick workaround would be to go to Failsafe and uncheck Throttle Failsafe.
This will get you armed and flying but it is highly recommended you find the cause of this issue and fix it.

Yes, all the bars move, and I think I see where your going with this. I will try the disarm first z d see if it cures both my problems. Then go from there.

Ok, no matter where i put the PWM threshold, it still stuck in failsafe. I went up and down, when I went up with the numbers, I would move the throttle yup and,it would beep, and then beep again when i returned throttle to minimum. When I put the numbers below 950, (my calibrated number is 982) no beeps, but either position the LED still flashes two yellow flashes, pause, two yellow flashes, pause, etc.