Pixhawk Frsky telemetry passthrough

Hi to everyone ,

I’m Alessio from Florence Italy, I work with Pixhawk and Arducopter since 2014 , but I found a problem with a new machine.I start with Pixhawk 2.4.8 clone , FW 3.6.1 Copter , Serial 4 , protocol 10 , baud rate 57, I can’t found the signal from pin 2 (TX) of the Serial 4/5 connector , but if I change protocol to Mav (1) I found output serial data.
What can it be that escapes me?

Are you using a serial inverter between the Pixhawk’s serial port and the receiver’s S-port ?

Yes ,the same used in many machines …but the problem seem to be on the pixhawk , no serial data found with my oscope.

Dev master code has now support for half duplex protocol on uarts. You can try that as well

Can you explain me ?

it is a development latest code build. not safe and should be considered experimental.
you can download its build from here for supported boards:

there is new option now for the configuration of the UARTs.
review this PR here: https://github.com/ArduPilot/ardupilot/pull/9749
it explains how to use it.

Paul , but it’s available a stable code ?

It is not available in a stable build yet, but you should not need it with the proper s.port converter. Also, I believe the port must be polled from the reciever side before any data is sent. I read something about that when I could not get it working. My problem turned out to be I picked the wrong serial port option, 4 instead of 10.

Option 4 pushes sensors preconfigured in the arducopter code into the radio. Passtrough is the option 10, needs yaapu lua script loaded in taranis radio - an amazing solution for telemetry. Try it, it all works. But, for now only in dev code branch, so, be careful.
I can be wrong but only FC with an embedded frsky sport inverter is a pixracer. And it still uses whole uart. New dev code allows to use a tx uart pin alone for half duplex communication like in betaflight.

1 Like

I’m not sure if this is your issue, but protocol 10 will not give you FrSky SPort messages directly understandable by Taranis. In other words, Taranis will not discover the sensors. You just need to use Yapuu telemetry script screen in your Taranis and everything will work like a charm. Here is the link:


I hope it helps!

Sorry… I gave the same answer as you. Only a correction… Pixracer FrSky SPort did now work for me… :frowning: Only option 10 and Yaapu script, wich is a fantastic solution… :slight_smile:

Anyway my question is not been satisfied , from pin 2 of Serial 4 port of Pixhawk I can’t see any signal when configured for protocol 10,my question is normal ?

For Telem4 you also need to set the SR4_XXX parameters to get telemetry output I think. For Mavlink you must set them, not sure on passthru but it won’t hurt anything. Also, there seems to be a time limit for sending mavlink data and writing logs. Log too many items and you don’t get any mavlink data. I am not sure what the rules are there either, but I have seen the effects.


afaik yes. it’s a single wire half-duplex protocol that requires a poll request containing the poll header and ID to send the requested data:

so if you just listen on the FC’s naked TX pin, there’ll be no data output.

cheers, basti

Try different port like tellemetry 2 to see if the port have some problem

I have been using a frsky X4R with my PixRacer FrSky Telemetry on SR4 using option 4 to the S-Port without any issue for several years. I decided to upgrade my system to the R9 Slim+ and the Telemetry is not passing anymore. There is a difference between the 2 for sure but I cannot figure out what it is. I tried both option 4 and option 2 and no telemetry. Do I need to use the inverted S-Port on the RX. Going directly into the S-Port of the R9Slim+ does not work. Moving back to the X4R works fine. Any suggestions?

Description says “with inverted SBus and SPort signals”
If you have a spare regular serial free, move your telemetry there. Racer’s FrSky port is already inverted.

Passthrough telemetry works ok for me. Pixracer’s sport is connected to slim+ A-connector’s S-Port pin.

@sergbokh I guess that passthrough Option 10 might actually be working but I just don’t see the telemetry updating. I guess option 4 does not work for anyone on the slim+?