Servers by jDrones

Pixhawk EKF is Red, LED Double flashing yellow

I am trying to get EKF 2 to function properly on my Pixhawk 2. When the Pixhawk turns on, the led flashes “double yellow” and the indicator on the mission planner HUD shows EKF in red text. When clicked on, a panel appears that shows velocity_horiz Off and pos_horiz_abs Off in red text. I have attached a picture of this below.

I haven’t setup an RC controller, so I assume that that is the source of the RC errors. Apart from that, the messages panel contains very little information as to what could be wrong. Once the MavLink connection has been established, the following is logged:

GPS: u-blox 1 saving config
Frame: HEXA
fmuv2 0048001E 33355102 34303335
ChibiOS: ff603d11
ArduCopter V3.6.3 (63eb66fe)
u-blox 1 HW: 00080000 SW: ROM CORE 3.01 (107888)

The ‘Arm/Disarm’ action returns ‘Error: command rejected by MAV’. In the PreFlight Panel, all conditions are either green or white.

Here is a pastebin with all of the parameters.

And here is a picture of what the EKF panel is showing:

I would be grateful for any ideas/suggestions you have as to how I can solve or further debug this problem. Thank you for your time.

Very high HDOP and low number of sats locked (5). That is where your pos and vel errors come from.

Once the GPS settles with more sats and lower hdop errors will go away.

So, bottom line is that you have to see if gps has something wrong to justify those poor performances.

Command gets rejected because hdop is too high probably.

Corrado

@MrLaggy i am facing same problem. EKF is RED. Did you solved your problem???

as anon67614380 said it because of high HDOP it will go away when HDOP below 1.5.
you need more than 7 satellite.
and note that flying in loiter with lower than 12 satellite is not good and dangerous.

here 7-12 satellite. EKF always red. How i will recover the problem. :black_flag:

its better to see logs from your fc
set these parameters :
LOG_DISARMED=1
LOG_REPLAY=1
and turn on your fc and arm motors but not fly then send log file for a better analysis

Thanks @hosein_gh i got it

But i am facing another problem. My copter will be fly always in indoor. i have used range finder for indoor fly. When EKF signal is RED then can not get value from range finder sensor (i mean altitude value fracture or use barometer). When EKF signal is good then work and get value from range finder sensor. As my drone will fly always in indoor. So there are bad gps signal. So how i will overcome the issue. Help me.

@borhanreo
When you fly in door you will not get an low HDOP

You can disable GPS in prearm checks

But never use Loiter , rtl , srtl or auto mode because they need gps 3D lock and low HDOP

@hosein_gh thanks, i am sorry for late replay. My mission planner version show armin%20check

I have unchecked the All tab. But same result EKF signal is RED altitude source used barometer not rangefinder. i want use range finder always.

Hi
Its hard to help without logs
Please set LOG_DISARMED=1 and send log to find problem

My Log

I want use always my rangefinder not barometer.

EKF is red because of high HDOP when you fly indoor or not using auto mode you can ignore this.

about rangefinder did you read this link

acorading to wiki downward facing lidar are used in flight modes which have height control
you can try althold mode indoor to use rangefinder

Thank @hosein_gh for you quick replay I read that link. My Rangefinder (Maxbotix analog) work properly and get sonar value. i think there are no problem. Problem is that When EKF red then pixhawk read from barometer. When EKF is white then pixhawk read from maxbotix and working well. You know my copter always fly in indoor. so there are high HDOP in indoor. as a result EKF always RED and use barometer sensor for altitude.

try to disable gps and remove gps from FC

  • Disable GPS in non-auto modes - set AHRS_GPS_USE to 0
  • Disable GPS_FAILSAFE

also do this :

I did AHRS_GPS_USE to 0 and did not found GPS_FAILSAFE. Even i disconnected all of GPS wire connection from FC. Now i got EKF status is white. But there are raise an another issue. FC did not use altitude value from range finder. It FC also used barometer.

What is flight mode?
Test with althold mode

I did not fly copter. just power on FC then i saw. I wan to use guided_noGPS mode

i’m not sure (must look at source code) but i think after take off it will use range finder

1 Like
Servers by jDrones