Pixhawk DShot Issue

There seems to be strange behavior with Dshot on the Pixhawk v2 cube black and Pixhawk v1. We are using APD 120a F3 esc’s.
3 pixhawk 2 cube black’s and one pixhawk 1 have been tested; all yield the same results.
On the contrary; Pixracer R14 works well.

Mission planner’s motor test feature is used. Motor spin is “bumpy” at certain speeds and there seems to be addressing problems between output channels (i.e. motor A can spin A and B sometimes). Too much throttle and the esc’s seem to reset. Looking at the output on an osciliscope; the wave form is sabertooth shaped rather than square shaped on flight controllers that work with DShot: https://slack-files.com/TJD3JCP41-FP15GFPSA-4113e5bfbc

Tried spinning from a PPM RX without a PC connection, powering from UBEC and a Power Module v1. This did not have an effect.

Paramters used:
MOT_PWM_TYPE: 4-7 all tested
SERVOX_FUNCTION: 1-8 disabled
SERVOX_FUNCTION: 9-14 set as motor 1,2… etc
BRD_PWM_COUNT: 4-8 tested
RELAY_PIN: Disabled

Any enlightnement would be highly regarded.

Have you disabled or re-purposed servo1-4/8?
I use the Cube and though didn’t check with oscilloscope, never had any of your experiences.

Yes forgot to mention,I have disabled SERVO_FUNCTION 1-8 and thanks for the quick reply. Are you using the same ESC’s?

@Simon_Raimbaud, no , I use tmotor esc’s.
However, with my limited experience if two motors are running at the same time in motor test, I believe you need to look at the wiring level, but as I said limited experience.

Ps what frame type is set?

When plugging the esc’s into a Pixracer or F3 betaflight FC, they work fantastic which is why I am led to believe that this is not a wiring issue, but the suggestion is appreciated. X quad is the frame type.

If you’re using 3.6.11 fw, you could share your parameters file, I can try to compare with mine?

That would be kind. Unfortunately, I do not have access to the parameters at present. Nonetheless, I can send you the parameter file Monday if you wish. It should be noted that all other un-mentioned parametes are default. 3.6.11 is used but beta fw and older versions were also tried.

sure, PM me when you want to.

I,as well tried to test the APD X-Class 100A on 12S and U8 Pro motors using DShot 300 off a Pixhawk and a Black Cube with the specific settings and got erratic behaviour and ESC resets.
I don’t have any Pixracers, so I didn’t get any succesful spin, but I can try Pixhawk 4 (regular and mini) and Orange Cube this week.

I have tried the Pixhawk 4. Got clean square wave Dshot signal on the first 4 AUX ports but I could not get any output from AUX 5-8 regardless of fw setup. I did not mention this as I think the issue is unrelated and I count on making a separate thread as soon as possible. But do share your findings Cornel, that would be greatly appreciated.

Did you ever get this working?