Pixhawk does not recognise NMEA input (Edit:Solved)

Hi everyone,

I am attempting to input an NMEA signal into a Pixhawk running Copter 3.5.4 but I’m having trouble getting the Pixhawk to recognise the signal.(I know NMEA should not be used for flying but please humour me) The signal is being sent at 5 Hz with a baud rate of 38400 and with GGA, RMC and VTG sentences as shown below. (Are all three of these sentences required? Are there any extra sentences required?)


The relevant Copter parameters are set to:

Is there anything I could be missing here? Is there a minimum NMEA version that I should be using? Are there any other parameters that need to be changed from default for this to work?

Any help would be greatly appreciated.


Edit: I answered my own problem. A PC serial port of course does not operate at TTL voltage. An FTDI cable fixed the issue.

Hi Luke

Did you reach any conclusion to the necessity of nmea sentences.
I am trying to inject (artificial) GPGGA sentences to PixHawk 2.0.
GPS is recognized at power up (once) and after that not. (Tried to vary latitude over time)
Also it seems that altitude is not really reacting to the GPS altitude.

Any ideas ?


PS: running for a level converter :wink:

try removing the VTG