Servers by jDrones

Pixhawk decrease throttle when RC signal is lost


(Demerval Gonçalves) #1

Hello everyone, greetings!
I have an FX-79 airframe with Pixhawk (firmware 3.7.1) and GCS with Mission Planner 1.3.49.
I tried twice to make a planned flight in auto Mode and both failed (logs and video of the second flight in the link below).
Apparently, when the RC signal is lost the acceleration decreases and nose is up, leading to the stall.
I investigated the logs, but I could not identify the reason why Pixhawk had this behavior.
Relevant information:

  • On both occasions, the acceleration oscillation occurred at the moment the RC signal is lost.
  • In Mission Planner FailSafe was configured only for GCS (attached figure).
  • The RC’s FailSafe is off (i6).
  • The problem starts at 09:51:46.881, with the reduction of AirSpeed and GroundSpeed.
  • The Stall Prevent parameters must have worked for the recovery of the aircraft.
  • The Radio FailSafe (FS-i6) is set to 50% acceleration in case of signal loss. On the first attempt RC’s FailSafe was off and my expectation was that by keeping the acceleration at 50% the problem would not recur.
  • It was not a problem in the battery, because the variables Current and Volt present normal values.
  • It was not mechanical failure.
  • It was not the strong wind.
  • It was not a bird attack.
    Anyway, I would like suggestions to clarify the fact that Pixhawk slows the acceleration during the Auto Mode at the moment of loss of the RC signal.
    If that’s not the problem, what would it be?
    Thank you for contributions.

Onboard Video
https://youtu.be/CwPJWBIA3Ps

Bin
https://drive.google.com/file/d/1ypRnKb-dtm8GAkaWErWIkt9zfaxPBJk-/view?usp=sharing

Tlog
https://drive.google.com/file/d/1xXxqmmPgrNjzGpdWP3ZTWdptv7Hv0duQ/view?usp=sharing

Print MP
https://drive.google.com/file/d/1qDHjZGGHir6YbQTpj3K4azEG5kZok8ej/view?usp=sharing


(Brian Christal) #2

Where is RC signal loss? RC3 IN is good the entire flight.


(Demerval Gonçalves) #3

Hi bchristal. Thanks for reply.
When RCIN.C3 decrease means that RC signal is lost. I configured RC failsafe to 1514 pwm.
In the range shown in the figure, when the orange line oscillates the RC signal is lost.
You can see that the RCOUT.C3 decrease (blue line) and Pitch increase (red and green lines) after this.
This is the point. The mistery.


(Graham D) #4

A couple observations and a suggestion: using a non-standard failsafe value is not advised and can lead to unexplained behaviour. The RC failsafe is supposed to go to below 950 pwm when signal is lost, it’s not supposed to, and the software is not designed to use to 1514pwm i.e. around the mid point. Normal range is 1000 to 2000 so below 950 indicates something is wrong and AP uses that value to trigger the failsafe condition. Basically anytime the pwm is below 1514 your system is in condition failsafe potentially leading to all kinds of unexpected behaviour.
For example: is throttle nudge enabled? If it is and you lower the throttle from high to just above or below your failsafe value then the system will use less throttle.

Not sure how you calibrated the throttle either - is it 1513 MIN to 1673 MAX?

Also if you go from manual to auto, AP can use different values like THR_MAX and TRIM_THROTTLE.

So I would set the pwm failsafe value to the correct value and try again.


(Demerval Gonçalves) #5

Hi, Graham_Dyer. Thanks for support.
Throttle Failsafe in Mission Planner was disabled. Only GCS Failsafe has been enabled.
However, on that flight (which was my second attempt) I configured the RC Failsafe (i6) to maintain the acceleration by 50% in case of loss of radio signal (trying to solve the problem).
But the inexplicable behavior was the same as the first flight, in which we had the following configuration:

  • Throttle Failsafe: 0 (disabled)
  • FS Pwm: 950 (I think if Throttle failsafe is disabled this value is ignored)
  • RC Failsafe (i6): off
  • GCS failsafe: enabled (but the telemetry signal was strong every time)
    You can see the print of the moment of loss of the signal (orange line down to 950) and the problem occurs (acceleration down (blue line) and nose up (red and green lines), leading to stall).
    The complete log of first flight is the link (problem after eighteenth minute (11:01:07):

https://drive.google.com/file/d/1RoDSWaa5k69SpLMKqbnoKmlOtK4KkKFq/view?usp=sharing

YES, the throttle nudge is enabled. Is this then a cause of the problem???


(Graham D) #6

Interesting, I see that RCOU.C3 dropped at first during the first period of low RCIN.C3 then recovered about half way through, that seems to suggest that it may not necessarily as a exclusive result of the low RCIN.

However I would definitely try with throttle nudge disabled and see if you can still detect the problem.

When I fly in Auto I put my throttle on the Tx at 50% and leave it there but I have no throttle nudge and when I get a failsafe there is no change in aircraft behaviour. I have flown 400hr professionally and regularily flew BVLOS out to 30km, I always turned the Tx off just after launch though, and never saw that. However my THR failsafe was always enabled and set to “continue in auto” else RTL. I wonder if, as that is disabled you’re getting some weird effect. But first to test with throttle nudge off to see if it’s that.


(Antonio Reis) #7

Just to confirm if you have changed the “fly mode” on these points.
It’s what I told you yesterday. When you lose RC is not just about channel 3. If the RC failsafe is not enabled, it will change your “fly modes”.

Please note that throttle don’t have any influence in “AUTO MISSION” so even that your throttle down to 0 it should not influence your AUTO MISSION.


(Demerval Gonçalves) #8

I’ve already done successful flights with RC signal break (even with the same configuration, but with a lighter wing).
And I could see a quick downward oscillation of RCOU.C3 at the time of signal failure (figure: peaks on the green line).
I think this can be seen in your logs as well.
I hope my problem is only with THROTTLE_NUDGE.
Congratulation for your BVLOS.


(Demerval Gonçalves) #9

Yes, all changes in flight modes were intentional. Including the RTL, accepted by the radio with oscillating signal, that saved the aircraft.


(Antonio Reis) #10

My suggestion is:

1 – Setup the RC failsafe (Channel 3 to -120%) as described in previous post
2 – Enable the RC failsafe on mission planner

NAME VALUE

  • THR_FS_VALUE 950 (check if this values are ok after setup RC failsafe)
  • FS_SHORT_ACTN 0 (0 means continue and 1 means RTL)
  • FS_SHORT_TIMEOUT 1.5
  • FS_LONG_ACTN 0 (0 means continue and 1 means RTL)
  • FS_LONG_TIMEOUT 5
  • FS_BATT_VOLTAGE 0
  • FS_BATT_MAH 0
  • FS_GCS_ENABL 0 (0=Disabled, 1=Enabled up to you)

3 – Calibrate your radio on Mission Planner
4 – Test your setup

Basic test:
1 – Remove propeller
2 – Turn on your radio and your plane
3 – Put the radio on stabilize mode
4 – Turn off your radio and check on mission planner if it enters in failsafe mode

Field test
1 – Setup a simple mission.
2 – Start your mission
3 – Turn off radio
4 – Check your GCS to see if it enters in failsafe mode.

More information here: http://ardupilot.org/plane/docs/apms-failsafe-function.html


(Demerval Gonçalves) #11

I tested and RC setup and PWM values are right.
The problem is that the action defined in FS_LONG_ACTN is the same for RC failsafe and GCS failsafe.
I need FS_LONG_ACTN for RC to be ‘continue with mission’ and FS_LONG_ACTN for GCS to be ‘RTL’.
Previous versions of the MP had the option to enable RC failsafe and choose a specific action for it (see figure).


(Demerval Gonçalves) #12

Hello everyone.
Two parameters were changed and new flight tests were successfully performed.
New values:
STICK_MIXING = 0
THROTTLE_NUDGE = 0
By disabling them the radio signal was totally ignored in the AUTO mode, allowing the flight to be performed only with the GCS.
Have good flights.