Pixhawk Clone. Won't AutoTune!

I have a Pixhawk clone from Bangood which I can’t get into AutoTune!

I switch into LevelHold and all is fine. I then switch into AutoTune and nothing!

The Mavlink tells my Taranis that the quad is in AutoTune!
Mission Planner says I’m in AutoTune!

Any ideas would help?

Many thanks.

We need to see the log to be able to help. Thx


Many thanks for reply.

I’m assuming that I produce this log from MissionPlanner, is that correct?

Not done it before so some pointers would be of help.

Many thanks.

@ jimbo385,
It is in the Wiki http://rover.ardupilot.com/wiki/downloading-and-analyzing-data-logs-in-mission-planner/

try copter.ardupilot.com/wiki/missio … -analysis/ in the wiki

Thanks guys,

I’ll look at both and give it a go.


Unable to upload my logfile as it’s just over 4mb raw and 2.9 zipped!

Therefore, I have put the file on Dropbox here.


Hopefully this works and is allowed!



Your channel 7 is set correctly and is seen in rcin. Looking at your pitch and roll RCin they look fine at about 1500, but your rudder seems a touch lower at 1470. Not sure if that is enough to stop auto tune, but do you have any trim on rudder on your radio? Not sure if its that but a possible and easy to check


Now that is very interesting!

The model I have is an FPV550. The configuration is very odd and even worse than a reptile quad.

This picture shows it’s configuration. I initially had a KK2 FC on board but it could not handle it no matter how I tuned it. So I thought Pixhawk!

In the configuration, I could select Quad but this looked symmetrical, so, what I chose was the V option but without the V-Tail! However, when I input yaw, I still get one of the motors pitching more than the other which is what I was trying to overcome with the Pixhawk!

Could this be the problem with YAW? In Missionplanner and Radio Calibration, I get the following ;

                      Left         Centre       Right
    Roll           1012        1517          2006
    Pitch         1010        1513          2006
    Yaw            982         1464          1988           

Is the above what you mean that Yaw is a bit off?


I would choose normal quad rather than v tail if it were me.

What I mean by the yaw being off is the RC channel from the radio. the RCin logs show wht the brain is receiving from the receiver. But yes that centre value for rudder is what your logs say. I am wondering its over a limit to allow autotune to run.

Have you got any rudder trim on the radio on?

Autotune stops running if you move the sticks so you can re position the quad.


No rudder trim in at all!

I have changed the model type from V-Type to X-Type. I have also re-calibrated everything!

Yaw still gives me the same center value.

Just one thing that really messed with my head and that’s Pitch! The quad flies great but on the MissionPlanner monitor, the Pitch is reversed! Is this normal?

Will hopefully be testing sometime tomorrow.


Are you talking about the horizon screen? Pitch should not be inverted. nose up should show more blue, down more green

No, not there. I’m talking about the RC setup/calibration screen.

Didn’t quite go to plan!

Will do a firmware upgrade later tonight and start from scratch.

Now what’s going on!

I installed the latest firmware and calibrated everything including the esc’s.

Now I’ve got very little power going to the motors! Certainly no full power!

I’ve tried 3 times to load everything with the same result.

Any idea?


Post a data flash log

sent from my phone so apologies for any typos

Ok. Will do when I get home. Cheers.



Here are the logs of my quad after reconfiguring as an x-type from v-type.

The problem is that I have calibrated everything after firmware upgrade including ESC’s but I’ve got very little power at the motors.


Those logs show a throttle input of around 13% but a pwm of over 2000 being seen from the receiver.
Your THR_MAX is only at 80 though, try increasing it to 1000

Hi Mark,

Many thanks for your reply.

I changed that from 80 to 1000 with no change! The quad still delivers very little power!