Pixhawk Clone. Won't AutoTune!

Did you do the all at once calibration?


Yes I did.

I’ve re-done the ESC calibration and now I’ve got more power!

Looks like Job Done!


Ok, thanks the changes to amend the throttle limits worked!

Now that it’s back flying I’ve noticed that the X-Type config appears to fly better. However, the quad still won’t go into AutoTune mode or Position Hold mode!

Here is a link to the latest log.



Looks like you are using a flight mode 8, but there isn’t one on this list. Are you sure you have set pos hold? I think there was a mode with a similar name at some point.

copter.ardupilot.com/wiki/config … erfltmode6

you had this autotune issue before didn’t you, looking again your channel 7 is operating, and ch7 option is set for auto tune so that looks ok. your pitch roll controls look centred too, which is correct. your yaw channel is still not exactly centred, but i don’t know if that is enough to stop autotune, looking though its not creating a slow yaw…so I think it should be working.

Hey Rabbitstu,

Yes I did have Position before so I really don’t know what’s gone on. As you say, my Yaw centre does appear off!

These are the steps I went through.

Upgraded firmware,
Used Wizard to get up n running.
Calibrated everything including RC
Calibrated ESC’s

Flew and produced log.

I’m not sure but I don’t think I have done anything wrong!


Here’s the instructions for autotune, it says you need to be in Alt_Hold copter.ardupilot.com/wiki/autotune/

Position was removed in favour of a new ‘hybrid’ mode which was called Position Hold. It’s a combination of Loiter when still, and Alt_hold when flying as this seems more natural to peoples expectations.

Now this is just getting strange!

After flying and producing the last log,

I’ve plugged in the battery and now I get a solid red light and the tone is like an SOS from the buzzer! It does this constantly. Have to remove power to make it stop.

Have searched and can’t find an explanation for this. I’ve not even switched on the TX! It does this with battery power or USB.

Looks like it’s going from bad to worse!

Sorted now!

The SD card wasn’t loaded correctly!

My bad!

The SD card wasn’t loaded correctly![/quote]
D’oh :mrgreen:

Cause I take it out to post the flight logs! Just didn’t put it back in!

Now then.

I have seen the MP needed updating so after that done, I now have PosHold and have set that.

All I need to do now is get AutoTune setup. As has been said, it appears to be configured correctly and is triggered. However, it’s not doing it! The Taranis is not displaying any trim but the centeris set at 1466. Don’t know why that is!

By the way,

Many thanks for all everyone’s help. Very much appreciated and I know that it’s all part of the learning curve.

maybe recalibrate the taranis, but I would then recal the rcinputs too after that just to be safe.

It might not fix it, but worth trying


I’ve recalibrated RCInput several times without success!

I’ve also recalibrated my Taranis and noticed that rudder center has moved!

Hopefully this may have been my problem and I hope that it hasen’t pushed all of my other models out!



Had to abandon Autotune after 15 mins!

Had to reposition loadsa times! Took 8 mins to do roll!

Battery warning got down to 3.6v so I had to stop and that’s on 5000mah batteries!

I think that the trick here is to try and not reposition as much. Therefore less wind required plus a much bigger field. This was a rugby pitch with the wind towards me.

At least I know it does it!

Many thanks for all the help.

Brill…do you think it was the rudder not being 1500 then…just so I know for future if I have or I see anyone have issues like you had.

Yeah pick a nice calm day if that’s possible :slight_smile:

I don’t think so because the rudder is still off according to Mission Planner.

However what I did notice is that the value of all channels on the Taranis changed after I recalibrated it.

The other thing I noticed whilst flying is that in Stabilise mode, the quad hovers between 1/2 & 3/4 throttle. When I switch into AutoLevel, the quad started to climb! So, I when I switched into AutoTune, it didn’t work. I had to stop the quad rising & falling by putting throttle at exactly /12 way! Then Autotune kicked in!

So, One lesson is that in Autoleve, the throttle must be 1/2 way which stops the quad rising and falling.


Ah OK. Aurotune is best done in alt hold which by default requires mid throttle. Good to know its blocked by non mid throttle for reference. Cheers

sent from my phone so apologies for any typos

Autotune Successful!

The Mavlink unit is brilliant by the way because my Taranis told me when Autotune was completed!

One thing though flying around with the Tuned settings gave a definite pitch & Roll oscillations which I now need to tune out.

Autotune has given me the attached settings.

[attachment=0]AutoTune Results.jpg[/attachment]

I think that 10 is way too much! Am now going to set CH6 up to tune Stabilise Pitch/Roll KP. I think that I will set the Min & Max to 4.5 and 10.0