Servers by jDrones

Pixhawk and Marvelmind Integration - Tank Rover

Hey guys,

I’m a beinger of ardupilot.
First, I want to build a robot like this video https://youtu.be/efOc-ItVvgg.
So I decide to build a tank rover first.

Then, I bought a HW4.9 starter set. After I unpack the starter set like this video https://www.youtube.com/watch?v=sOce7B2_6Sk
After that, I start to set up in Mission planner for the tank rover.
I uploaded ArduRover V4.0.0 firmware to the pixhawk

About the parameter of pixhawk
I modify as follow(follow the instruction that Marvelmind company recommand https://ardupilot.org/rover/docs/common-marvelmind.html):

-SERVO1_FUNCTION = 73 (Throttle Left)
-SERVO3_FUNCTION = 74 (Throttle Right)
-AHRS_EKF_USE (I cannot find this in Mission Planner)
-AHRS_EKF_TYPE: 3
-EK3_ENABLE: 1
-EK3_IMU_MASK: 3
-EK3_ALT_SOURCE : 3
-EK3_GPS_TYPE: 3
-BCN_TYPE : 2
-BCN_LATITUDE, BCN_LONGITUDE (I obtain this valve from google map)
-BCN_ALT :50 (Our office is 13th floor, so I assume about 50m from sealevel)
-BCN_ORIENT_YAW: 90 (I hold the robot and stand at address 2 beacon, then point the pixhawk arrow to address 2 beacon to obtain this valve)
-GPS_TYPE: 0
-Arming Check: -9
-Arming Require: 0 (I follow the Ardupliot forum said need to disable this valve as well)
-SERIAL1_BAUD: 115 (I do not know 1 or 2, so I choose 1)
-SERIAL1_PROTOCOL: 13
-BRD_SER1_RTSCTS (I am not sure using telem 1 or 2, so I choose 1 again)

According to Pixhawk and Marvelmind Integration Manual (https://marvelmind.com/pics/PixHawk_Marvelmind_Integration_Manual.pdf)
I also modify the “Yaw” at 270 degree in compass (INITIAL SETUP | Mandatory Hardware | Compass and make this correction in the panel “General Compass Settings”)

About the DashBoard setting, I modify as follow:

Modem:address :8
Interface UART Speed. Bps: 115200
Raw distances data: Enable
Georeferencing: Obtain from google map as well

Hedge 1:address: 1
Hedgehog mode: Enable
Interface UART speed. Bps: 115200
Protocol on UART/USB output: NMEA0183
NMEA message $GPRMC: Enable
NMEA message $GPGGA: Enable
NMEA message $GPVTG: Enable
NMEA message $GPZDA: Enable
External Device Control: General robot control
Raw distances data: Enable
Ultrasound: Duty%: 50

Stationary beacons: address 2-5
Ultrasound: Duty%: 50

All stationary beacons height manual set as 1.82m.
Stationary beacons 2-5 set in Submap 0
Hedge beacon set in Submap 1

The mission planner did not receive any GPS signal at all, but the Dashboard of marvelmind can track the live movement of the Hedge. I can motor test the ESC at mission planner and it’s work. The HUD of mission planner also have reaction too. Also, all the calibration done.

Am I suppose to see on the autopilot, (the main LED should blink green, and on the “FLIGHT DATA” page the message “3DFix” should appear on the navigation bar in mission planner)?

Is it suppose a logo of my rover should show on the map in mission planner if I set it right?

For now, the wire connection show below pic, I did not have any RC remote, is it not necessary to control the robot without it?

Finally, I just want to make it work like the first video, but I try my best to troubleshoot what happen and I’m feeling lost.

Many thanks.

in the https://discuss.ardupilot.org/c/ardurover/8 group you will certainly have more luck to get an answer. Could and admin move it to the right place please?

Servers by jDrones