Pixhawk and Electronics Flashing Green

We have been putting together this build for a while now and we began to test the motor when suddenly the Pixhawk 2 along with the other electronics attached to it started to go haywire. They all blink and the Pixhawk flashes green repeatedly. We assume this is the Pixhawk trying to save itself from too much or too little voltage however we tried again with a different battery just with less mAh and it resulted in the same thing. We have changed out the power brick mini with another as well to no avail. It works when plugged into the computer via USB however when the battery is attached it flips. We also tried a different Pixhawk and we get the same result. Everything had worked fine for weeks with everything plugged in until we tried to calibrate the motor and set in Mission Planner to the automatic arm. The ArdoPilot firmware used is AP 3.9.8. Any ideas?

Here’s our setup:
SunnySky X2820 KV800 Motor
Flyfun 60A ESC with BEC capable of 7.4V
Pixhawk 2 Black cube
Power Brick mini
3DR radio
D4R-II telemetry

Welp all good. We found out that it was just our LiPo batteries running low.

It supports POWER BRICK MINI 30 amp current. Wouldn’t this cause POWER BRICK MINI to burn?