Pixhawk 4 Power Module Readings Not Working


I just flashed my Pixhawk 4 with Copter 3.6.1 using Mission Planner. However, when I connect the battery to my power module, I don’t get a voltage reading. I wired up my Pixhawk properly according to this Document. I have also read this article about how to set power modules in Mission Planner. Here is what my screen looks like, indicating no voltage readings:

I tried different batteries to ranging in different cells and capacitance.

I know it isn’t a hardware issue because when I flashed the board with PX4 using QGroundControl, I get proper readings. Here is what it looked like:

Is this a bug in Ardupilot or Mission Planner? Or am I not setting it up properly?



Thanks for the report. I suspect the issue is the BATT_VOLT_PIN needs to be set to something else but I’m afraid I can’t say what it should be set to… :-(. Maybe @tridge knows…

BATT_VOLT_PIN should default correctly to 0 on a Pixhawk4
BATT_CURR_PIN should default to 1

Thank you guys for the response.

I think it is a issue with Mission Planner. The flight controller is flashed with copter 3.6.1 and works with the daily build QGroundControl. On Mission Planner I still don’t get any voltage readings. But with QGroundControl I do get voltage readings. Here is a picture of the correct voltage readings on QGroundControl:

Here is a picture of my screen confirming the Voltage and Current pins are set correctly in Mission Planner:


Am I not setting it up properly with Mission Planner?


Hi - I have the same issue. Did you ever get a resolution?