Servers by jDrones

Pixhawk 4 no DShot from AUX channels 5-8

Strange discovery when attempting to run 8 DShot esc’s from a Pixhawk 4; no signal output from channels 5-8. The 8 channel breakout is connected to the “FMU PWM OUT” port. Ports 1-4 work fine and output a clean signal (observed on oscilliscope). Tried setup parameters for hex and octo and still only 4 outputs work. ESC’s used are APD 120A F3

Parameters:
MOT_PWM_TYPE: 4-7 all tested
SERVOX_FUNCTION: 1-8 disabled
SERVOX_FUNCTION: 9-16 set as motor 1,2… etc
BRD_PWM_COUNT: 4,6,8
RELAY_PIN: Disabled
RPM_PIN: Disabled

Tried quad params with servo functions 13-16 (AUX5-8) as motor 1,2 etc also; Nothing
Also tried auxilary power to no avail.

If anyone has wisdom to cast on this subject, that would be heroic.

Did you check SERVO_BLH_OTYPE?

http://ardupilot.org/copter/docs/parameters.html#servo-blh-otype

I have just tried to set SERVO_BLH_OTYPE to DShot300 to match MOT_PWM_TYPE and setup for HEX but unfortunately this did not make a difference. Note that I have SERVO_BLH_MASK and SERVO_BLH_AUTO disabled as by default. Thanks for the suggestion none the less.

Keeping those settings and enabling SERVO_BLH_MASK to channels 13 and 14 seems to prevent DShot output on all channels.

Hi Simon,
Have you managed to get this working? I am experiencing exactly the same issue.
If not, can anyone else shed any light on this?
Cheers,
Sean

Update. They are all working after setting MOT_PWM_MIN to 1000 rather than 0. So I think it might be a calibration issue.

Hi Sean glad you got it working. Good to know that it is possible. I just tried what you suggested though and it did not make a difference for me. Did you change anything else?

Servers by jDrones