Servers by jDrones

Pixhawk 4 FMU v5


(John DeVere) #1

Are there ardupilot builds for the pixhawk 4 yet?


(Khancyr) #2

Hello,

No there isn’t for now. And no ETA.


(Graham D) #3

Yes, trying to load the Ardupilot stack via QGC on my Pixhawk 4 fails as it does via Mission Planner too.

Looking forward to being able to run all of Ardupilot on the Pixhawk 4


(OldGazer) #4

Have you tried using the PX4 stack that is pre-installed?


(Graham D) #5

PX4 doesn’t seem to have the features, support or development of Ardupilot. And as far as I can tell doesn’t support a tricopter VTOL.


(John DeVere) #6

Px4 and dronecode are the same aren’t they?
Yes, I verified it boots.

Who adds the new processor type to the build system?


(James Pattison) #7

No one on the dev team has one of these. It’ll be at least 2 weeks until we get one.
There is an initial PR for fmu-v5 here: https://github.com/ArduPilot/ardupilot/pull/8533
But it’s incomplete, almost untested, and based on the cuav v5, not the Holybro v5.


(John DeVere) #8

Can I send one or two out to someone on the dev team?


(tridge) #9

yes, there are, I’ve put them here:
http://uav.tridgell.net/PixHackV5/
This was developed for the CUAV PixHack-V5, but should work on the Pixhawk4 too. I’d appreciate it if someone could test it.
Note that this is very preliminary code.
If you want to build the code yourself you can get the source here:


Cheers, Tridge


(John DeVere) #10

I loaded the June 8th build of arducopter firmware successfully, configured as quad x, calibrated the IMU and Compass —no issues to note

I don’t have a test quad ready to do much else… hopefully, I’ll have time this weekend.
I will of course post if I run into an issue.

If there are any specific tests I could do for you, please let me know.
Thanks,
John


(Douglas Lorenz) #11

Hello all, new user here, just got a Pixhawk 4, and have been just starting to set up the software. I had originally planned on going Dronecode, but I think I’d rather go with arducopter instead. I just downloaded the “Test 8” version of arducopter, but wasn’t able to successfully upload it to my Pixhawk 4 using Mission Control.

I’m probably doing something stupid, but can someone tell me how to upload this firmware?


(Chris Olson) #12

I’m not exactly sure what Test 8 is. You have to get the latest fmuv5 for either heli or multirotor from here. It should be called something like arducopter.apj or arducopter-heli.apj. It is ChibiOS build for the FMU V5.

http://firmware.ardupilot.org/Copter/latest/


(Douglas Lorenz) #13

Hi Chris, thanks for the quick reply…

I did that, then tried to use Mission Control to upload the file, but got errors. I have no idea what I did wrong, and was just looking to see if there was a simple “how to” upload an apj file to my FC in a “for dummies” sort of way…

–Doug


(Douglas Lorenz) #14

Excuse me, I meant “Mission Planner 1.3.56” when I wrote “Mission Control”…

–Doug


(Chris Olson) #15

OH, I think you have to get the latest Mission Planner too (the beta). As far as I know it should load a .apj file fine. QGroundControl is the only ground station I have loaded the V5 with in my Developer Edition Pixhack V5. But I had understood the latest Mission Planner beta does this too.


(Douglas Lorenz) #16

Ok, just upgraded to Mission Planner 1.3.56.4 and tried again.

I went to “Initial Setup”, then “Install Firmware”. I clicked on “Load Custom Firmware”, and selected the previously discussed apj file.

The end result was the same error that I’ve been getting whenever I do this:

Capture


(Chris Olson) #17

OK, I don’t know. I don’t have Windows. So I did this on linux. First I got this version of Mission Planner

So then I go to the firmware page and click on load custom firmware

Select my downloaded build

It erases my Pixhack V5 and I get the progress bar while it’s loading the latest dev build

Then I connect to it and verify what git revision I got - seems to work fine here

Screenshot%20from%202018-06-23%2021-37-08


(Douglas Lorenz) #18

Hmm…Thanks for the sanity check. I 'd been doing it the same way you did, but keep got a different result.

I’m on Windows, maybe that’s the problem. I’m going to go put together a linux computer out of a SBC and give that a try…


(Chris Olson) #19

Yeah, I usually don’t use MP on linux. I just have it installed for reference. I normally install with the command line with waf after building the latest. But if I use a ground station I use QGroundControl. The waf build creates a .bin file as well as a .apj and that .bin file loads fine with QGC.

AFAIK the Pixhawk 4 has the identical hardware in it the Pixhack V5 has, so it should load the firmware the same way and it should identify the board type as fmuv5.


(John DeVere) #21

You need to verify the com port and make sure you have the right one selected first…