Pixhawk 4 - Check BRD_TYPE: Baro: unable to initialise driver

Hi All,
Today I took new Pixhawk 4 from my store and started configuring with Arducopter V3.6.10. After porting the firmware I saw this error in Mission Planner PFD “Check BRD_TYPE: Baro: unable to initialise driver”. (I tried ArduPlane also, same result :frowning: )

I have then ported PX4 firmware to check whether it’s hardware issue. After porting I checked the nsh and baro is perfectly working (I can see MS5611 in the list :innocent:).

I have tried with another Pixhawk 4, and AC V3.6.10 is initialized perfectly.

Any idea, how to go ahead???

Thanks in advance :slight_smile:


did you check what the BRD_TYPE parameter is set to? If it does not automatically detect, you can manually set it to your board type.

Hi Arjun,
Thanks for your information.

Sorry, I missed that in first post. I have already checked that
BRD_TYPE value is 24, for Pixhawk4.
Even tried manually setting BRD_TYPE value to some other values.

I’m not sure what the problem is . But , can you try the dev branch (instead of v3.6.10) and see if you see the same problem?

Yes, I think @arjun7965’s advice is good which is to test Copter-4.0.0-dev. Alternatively try testing with either Plane beta or Rover beta which are very close to “latest” and include all our new drivers.

It seems to me though that because other Pixhawk4 boards are working there is either a hardware issue or the sensor on the board has changed and our the AP driver is not compatible for some reason.

Thanks for your reply @rmackay9 & @arjun7965.

I tried with ArduCopter V4.0.0-dev and it is initialized properly and no BRD_TYPE error. It’s working perfectly.

Now what will be the issue with this Pixhawk4 device.? As I mentioned earlier I saw MS5611 driver running using PX4+NSH. That means the Baro is nothing but MS5611, isn’t it?

I’ve had this issue twice recently. New boards working perfectly, but after numerous flight time, at next boot up, craft remains in pre arm error.

Plugging into pc shows error as baro driver not initializing.
But it was working before.

Discussed with FC manufacturer and they agreed baro is defective.

I tried the dev4.1 firmware as suggested in previous reply with no change.

I tried loading qgc firmware which did load, but then reported baro missing.

Is it possible that after numerous landings the baro can detach from the FC surface mount board?

I have the same message when connecting the FC from the USB. If I power it from the battery then it is fine.

I am having same problem . I have updated and it will not init. If I load px4 on my cube black it will initialize. If i do aurduplane I am getting a critical warning and it is not seeing the board. this happens with and without a batt being plugged in. I am at a total loss.