Pixhawk 2 Shipped with bad safety switch twice

Hi all Video link you can see with your own eyes the board not booting up.


I found out why the board would not boot the safety switch was wired wrong again and shorted out the led power to the 3.3VVC pin so it would not boot.

Once I rewired it the to the correct pins it will now boot and the Safety switch now works as it should but you can’t calibrate the RC Transmitter.

The compasses and accels are fine and calibrate no problems but the short circuit must have damaged the input from the RC in put channels as the controller cannot see my transmitter inputs and I’ve tried two receivers and checked all my TARANIS X9E inputs and outputs they are correct and work on my other Pixhawk so I know the Sbus output is correct and working. The Calibration comes up bad channel one input and that’s that nothing from that point.

I’m very disappointed this has happened again what am supposed to do when the wiring harnesses are soldered to the wrong pins on two separate safety switches that I have now had to correctly wire and I have no idea what other damage has been caused to the board other than having no RC input from the receiver

Please try to email sales@hex.aero, I believe they should provide you with some solutions

1 Like

I have to add here that I have also just encountered a bad safety switch.

Symptoms are no LED in the switch and no operation when pressed.

Luckily we purchased 2 Pixhawk2.1’s and when I plugged in the other cable from the unused one it worked.
Internal LED lit up and pressing it enabled the signal to the ESC’s.

I retried #1 again and still no internal LED but it DID enable the ESC’s when pressed.

Looks like I will have to take it out and strip it down to find the problem.
A bit disappointed.

Hi Mike
Yes very disappointing but easy to fix your fine the positive and negative on your switch is wired back to front so the LED wont light up as its a diode and wont conduct in reverse polarity.
Just remove the heat shrink from the one that works then rewire the supplied switch.
Cheers Kevin

Yes @Kevin_Lunn, I have just done that.
The solder bridge on the plug lugs is between the wrong 2 terminals.
Just switched them around and now it works as expected.

For those with similar problems,mine was defective too…this is solution to proper wiring

Really sorry about this, yes, some of the safety switch cables came out with incorrect wiring. If you find this, please contact your re-seller, and they can organise with hex for you to get a replacement.

Again, I am sorry about this, we will ensure better for the future.

It will be very helpfull for us that purchase it from another country?

I’m also having problems with my brand new jDrones safety switch. However, I don’t seem to have the J17 connector, so am unsure about how to identify correct wiring. Here is what I have:


Is this wired correctly?

Happy Holidays!


BigAl,i guess you are using Pixhawk 1…here is pinout of Switch port

also check documentation for other pinouts

Thanks much. Yes, I’m using Pixhawk 1. I’ve got a multimeter on order and will test LED using meter diode test mode.

Same problem here, thanks for the scheme.

Well, it turned out that my safety switch was OK after all. I ended up using a product called Deoxit to clean some corrosion on the underside of the Pixhawk circuit board in the vicinity of the safety switch connections. I can’t prove that its use was the fix, but it has worked flawlessly since, and I basically didn’t do anything else.