Servers by jDrones

Pixhawk 2 - only 1 esc not calibrating

First time here, first time builder. I just got a pixhawk 2 and have fixed it up to a Tarot 650 sport frame with Tarot motors and Hobbywing xrotor 40A ESCs. When I perform the ESC calibration esc no. 1 does not calibrate - the other 3 calibrate fine and the motors spin. I can calibrate this ESC manually via the receiver. Also doesn’t seem to be the ESC, as I can switch around the cables and then it’s only the ESC on “main out 1” that doesn’t respond.

This leads me to believe that my “Main out 1” on the Pixhawk is faulty. Is there any way for me to:

a) Validate that the Pixhawk main out 1 is faulty?
b) If it is faulty - configure the pixhawk to use a different main out pin for that motor?

Thanks in advance!

If it’s an early issue 2.1 then the channel one fault is well known and there is a workaround available.

https://discuss.ardupilot.org/t/sb-0000001-critical-service-bulletin-for-beta-cube-2-1/14711

1 Like

Thank you! This is very good to know. I got my pixhawk from Spektreworks 2 weeks ago - but I suppose they may have sent me an early one with the fault.

Would you mind please explaining where to put the “SERVO5_FUNCTION=33” piece of code? I presume it’s somewhere in the mission planner parameter settings, but I’m still finding my way around in there.

You’re correct, it’s a parameter, which can be changed through Mission Planner. I forget exactly how Mission Planner organizes things, but look for advanced parameters perhaps? In case you look through the parameters and can’t find it, consider checking Mission Planner’s settings for some sort of “Show Advanced Options” and then look again through the parameters.

Post here more details if you still can’t find it?

1 Like

Thanks Hunt0r!

I found the parameters under “standard Params” and updated RC5_function to motor 1 via the drop-down. However, motor 1 still picks up nothing on that pin when the others calibrate normally.

I suspect I need to make the change somewhere else as well. Still trying to figure it out.

Spotted my own error when I posted the screenshot! Had RC14 instead of RC5_Function! It works now. Huzzah and thanks to all for the help!

1 Like

Allegedly,all the faulty ones were from the first batch way back last year.I got one of those and did the modifications to stop the potential shorting out.Your’s sounds like a hardware fault and not the “maybe” situation I had.Worth sending back for replacement I’d say.

Oh no! I ordered this from the US to South Africa - it took weeks to get to me! I don’t even know how returning will work in this case.

Further evidence the board may be faulty though - I can’t get the SBUS to work now - not powering the receiver or picking up signal in SBUS port when I power the receiver from the RC in rail pins. This is turning out to be a real headache.

Thanks for the advice!

Well you’ve got a work around working so…

Your radio needs to go to RCIN and not SBUS which is actually SBUS OUT (or passthrough) and is disabled in stock firmware loadout .

1 Like

Correct… Sbus RX plugs into the ppm plug.

Servers by jDrones