Pixhawk 2 can't arm

Hello everyone

I tried for several months to work my Pixhawk unsuccessfully
I can not arm the controller. When I press the switch, the red LED stops flashing and remains on, but the LED of Pixhawk still following blue or green flashing GPS reception there or not even Stabilize mode.

I find it equally impossible to calibrate the ESC, all procedures that I could find on the web or tutorial on YouTube does not. After the second disconnecting the battery the process stops

At first I configured the Pixhawk with Qgroudcontrol, then with MissionPlanner, but whether with one or the other problems persist

On the missionPlanner firware insalled is 3.3.3, the latest ,. I tried with the previous firmware, without changing anything to my problem

Thinking it is the pixhawk was defective I bought a second but the problem is the same with this one

My setup:

Ppixhawk 2 purchased from hobbygaga
power distribution plate with 2 spout (12 and 5 volt) purchased from hobbygaga (http://www.hobbygaga.com/fr-5-en-1-carte-d-amortissement-carte-de-distribution-d-alimentation-5v-12v-bec-courant-voltage-c-p270432.htm) all connected to a 6s lipo battery Turnigy my 16000
Module latest GPS (with Glonass)
telemetry module 433 mhz
Radio control Devo f12e receiver with 12 channels devo
6 Engine Emax 340 KV allimentés in 6S
6 ESC Emax BLHeli 40 amps

Can anyone help me

thank you

I don’t see the problem here. If Pixhawk is working then there is a blue flashing light and then green flashing if it has GPS lock. It does not turn solid until you arm the copter.

To calibrate the ESC’s I found that putting the throttle all the way up and plug in the battery. If you have Mission Planner connected you will see a message on the HUD say entering ESC calibration mode. Then unplug the battery and plug it in again. You should hear a tone from the motors and if you have mission planner connected the message will say in ESC calibration mode. Now lower the throttle to minimum and you should here the two beep tone from the motors. ESC’s are now calibrated unplug the battery or if you don’t have the props attached raise the throttle just a little to see if the motors all spin.