Pixhawk 2.4.8 yaw spinning


I’ve been trying to take my first flight, but I’m getting some weird behaviour. I’m using Qgroundcontrol version 3.4.4 and I have Ardupilot version 3.6.4 on my Pixhawk. My quad start spinning pretty rapidly in the “yaw” direction. I’ve calibrated my ESC’s multiple times, and that does not seem to do the trick. I’ve tried trimming on my remote, but that just makes two motors stop if I try to counter the spin. Does anyone know what I should do to fix this? Do I need to retune the PID or something like that?

Any help is appreciated.


(In case you don’t get a response here, you might try moving your post to the “ArduCopter” sub forum. There are more copter-specific experts watching there.)

Don’t trim from the transmitter, center those and leave them there. This is most often a case of improper motor order or motor direction. If you are certain you have that correct post a link to a flight log, there may be something obvious to see. Or a parameter file if you don’t have a flight log.

I have moved your post to the Arducopter 3.6 forum where it will get the most appropriate exposure.

Please post a .bin file from your flight controller so we have some data to look at to be able to help.
Any additional information you can give will also help.