Pixhawk 2.4.8 Not Armed in Mission Planner

Hello all

My pixhawk is RadioLink 2.4.8
After ended the calibration and solved all problem which showed on Data Screen

the data screen shows me “Ready to arm”
i tried to arm but i can’t
i don’t need GPS

what the problem should be ?

I not sure why you dont want the GPS but as it’s shown in red ‘GPS:No GPS’ on the display it’s probably the reason you can’t ARM!
If you go to the ‘CONFIG’ setting and then select the ‘FULL Parameter List’ in the search type ‘ARM’.
You will see ‘ARMING_CHECK’ in the value colum there will be a large number. Select that number and a window will appear.
If you really don’t want the GPS then deselect ‘GPSlock’ and possibly ‘GPS configuration’.
You should be able to ARM now but at your risk if you have a flight mode that needs the GPS!

1 Like

It doesn’t seem that you finished calibration… this check firmware or FRAME_CLASS is one of the first setup you should do.

1 Like

How did you get back to V4.0.7? Or did you post the wrong screen shot to waste more people’s time?

I posted this photo before editing

I respect that you are an expert in this field
But I hope you respect that I am trying to learn and benefit as much as possible from the experiences of existing people

You may see that I am wasting your time, and this is your right, of course
If you want, you can avoid my posts so that I can reach other people

In the end, my intention is very sound, and I admit that I am a beginner, and I will continue to raise my problems and benefit as much as possible from the experts here