Pixhawk 2.4.8 (FW 4.0.1) and YEP 40A ESC setup

Hi everyone,
I’d set my pixhawk with setpoint on ch8 to use in 450 class heli. I bought a YEP ESC to have GOV mode.
I tryied to program it with the program card and set GOV…
On my TX (taranis Xlite) I’d set switch to ch8.
I armed the copter but impossible to start motor. Even if I switch the ch8 on TX.
Qground control said me “interlock is on” but nothing, no motor.
How to config this ESC with a pixhawk? Maybe need to change setpoint value to config? Maybe I couldn’t setup via FC? Somebody have a tutorial?

Hi @aldelph
Have you read the tradheli wiki that describes the connections and motor interlock. You can find it here. If you don’t mind please post your param file so I can look at your setup.


Thanks for helping.
I red it. But YEP (YGE) Esc seems to be specific…
Idle is at 50, setpoint to 800
when I arm pixhawk, ESC set to config mode…

heli450.param (29.8 KB)

Motor start… the matter was throttle deb wasn’t set.
It run up to full full full speed…
And start when switch is normaly OFF. Stop when switch normaly ON. If I invert ch8, doesn’t work.

after a total inspection of parameters, servo8 was inversed… I don’t know why.
So, Arming seems to be OK and start with switch too.
I will change switch of ch8… more secured one. mine is too small and could be activate/disactiveted accidentally.

Glad you were able to work through that. Sorry I hadn’t looked at your params yet. I will do that as soon as I am able.

How did you setup the mode on the YEP? Simply on or did you conduct the whole setup?
I have the same esc and found a seven years old video on this.

here are some things i found with your param file

first you need to enable arming checks by setting this parameter as shown. This would have caught many of the issues I pointed out below.

You should consider disabling Compass 2 and 3 and only use the external compass on your GPS. To do so, make theses parameters changes

The crash check could inadvertantly disarm your heli in flight. You can read up on it but it is designed to shut down the motor if it detects that you crashed. you can disable it with this setting

Electric powered heli’s shouldn’t use throttle idle and it should never be this high. Highly recommend making this change

The RSC_SETPOINT setting is wrong. In 4.0, this parameter was all scaled from 0 to 100. This is why the arming checks are critical because this would have prevented you from arming and told you what the problem was.
This should be 80 not 800.

RSC_CRITICAL is also wrong. There is guidance in the parameter description on how to set this parameter.
I would recommend setting to 70 not 100.

H_CYC_MAX 30 <—Why did you make this change? This value seems very low.

What do each of these correspond to in degrees of collective pitch?
H_COL_MAX 1900
H_COL_MID 1500
H_COL_MIN 1150

That’s all I found. Please make the suggested changes and see if you get any other messages from the pre-arm checks. If you do, please post them and we can work through them.

Thank you very much!!!
I was setting only the motor.
But you’re very nice
Since I’d set other parameters.

I have a failsafe problem.
When the motor start. It runup for 10 second. Rotor turn at 80% speed. And after 10 second. Cutoff.
Telemetry said battery low fs. However, voltage is ok and capacity too…!!! I confirmed with multimeter and pixhawk sensor said good measure too. I don’t know why motor cut.

I’m not a heli guy, but you seem to have the voltage and current settings very standard and for approximately a 3 cell Lipo.
If it’s triggering low voltage failsafe then you’ve got a very poor battery (cells going bad), bad connections somewhere, or something is wrong with the voltage sensor values.
For 3 cell Lipo you should be able to use these values, or something is wrong:
You should set these and then fix whatever else is wrong causing the battery failsafe.

I have a problem with my voltage sensor and FS…
At motor stop, all is fine. voltage sensor give me the right value.
batt_fs is set correctly at low and critical values.

When I start motor, battery go down under FS value (3.93V!!!) so motor start, run some seconds and stop because failsafe go on.

However, voltage and capacity are good. sensor give me 97% and multimeter said the same. when I reload the batt, charger say 300mAH regain. And it’s the same with another batt.
it’s 2200maH 11.1V 25C batts
it’s the battery? Or it’s the sensor (I set power module 90A)?
motor had a runup ramp set to 10s. start current musn’t go above 25C!!!..
The worst is that it was running fine 2 days ago!!! and change something witch go wrong

helico 450.log (30.0 KB)

I noticed something. rotor runup slowly (ramptime 9s) and then go up freely (runup 10s). Battery fall down after those 10s. So maybe there is problem around those parameters…
gov set point is 80%. 80% of what? of ch8 PWM receved on RX? or 80% PWM max sets in pixhawk ch8 setup?

I precised that my ESC is GOVmode and I set the ESC min/max with ch8 switch on/off and pixhawk govsetpoint set to 100% with arming
Calibrating radio do the same result.

Here 2 logs. We see differences between two times. but can’t find the mistake…
this is the wrong one:
log_66_UnknownDate.bin (375.5 KB)

this is the good one

really, I don’t know why this batt fs appeer.
I test with setpoint to 45% and ramp time to 15 seconds, there is a voltage falldown but only 1.5v, so FS don’t stop it.
test at 60%, batterie shut down to 9,8v, so FS setup.
with the 2 batteries it’s the same.

I don’t know why my batt voltage fall down quickly at motor start.
And at motor stop, grown to initial voltage.

As mentioned earlier, bad batteries or not rated high enough for current draw.
What batteries are you trying to use, how old are they and whats the current draw?

It’s old batteries but not used so much.
2200mAh 25C. Was sold with the helicopter.
Set to 17.0 as it’s write for 3DR power module. But maybe I could affine it?