Pixhawk 2.4.8 + esc keeps beeping

Hi all,

I’m completely lost, I bought myself a pixhawk 2.4.8 to get my drone flying. On the pixhawk firmware I keep getting gps issue’s with ublox m8n gps not in sync.

So I switched to ardupilot, but now I’m get through all the calibration steps. It will first not arm cause fs_thr failsafe value. So I disabled that for the time being.
Now I am able to arm, but can’t get the motors to spin. Just all day, when troubleshooting this problem, the annoying beeping of esc’s.

If finished the autocalibration more then once, got the nice tune. After reboot in non calibration mode, it beeps like crazy again. Fast recurring short beeps.
Can someone enlighten me with what I’m doing wrong?

What is a Pixhawk 2.4.8?

@kd0aij I think it is this one: https://www.banggood.com/Pixhawk-PX4-2_4_8-Flight-Controller-32-Bit-ARM-PX4FMU-PX4IO-Combo-for-Multicopters-p-1040416.html

@Frank_Troost It sounds like you may have an issue with how your throttle is set up. Often ESC’s are programmed to beep in certain ways to alert you to what invalid signals they are receiving. Have you looked up the documentation on your ESCs to understand what they’re telling you?

What kind of RC Receiver are you using? Can you plug one of your ESC’s directly into your RX, to verify that your RC transmitter is setup correctly?

Or, you could check the throttle values using the RC Calibration page in Mission Planner too.

Finally, (and this may be a dumb question) what autocalibration are you referring to?

Beeping , even after pressing the safety switch …?

Thnx for the reply’s sorry for keeping you guys waiting for a response.

Ik get all sorts of errors in the normal px4 firmware but there I don’t have the esc beeping problem. There I get mag errors…

I’m using 9xr pro remote and reciever 9x8c v2.
30a esc without documentation, china ;).
Ublox gps

I want to use ardupilot but getting no motor spin is a problem in the ardupilot firmware. Gps and compass seem to function fine in ardupilot.

I will try the reciever calibration today. Let you guys know.

I did the reciever direct calibration, and it works, but still have the problem in arming with arducopter.

It seems like you’re making progress! If you want more help, could you describe the details of the problems you’re now having? (I can’t tell what issues have been resolved, and what hasn’t)

When I connect everything to the pixhawk, the esc + motors keep on beeping and beeping. It never stops and the motors will not spin. I have esc’s from China named hw30a.

Are you able to connect one of your esc’s to your receiver? If so, can your verify that they operate as-desired without the PixHawk?

A quick google search reveals that they have some auto-shutoff safety features that you may be experiencing, or they may have accidentally have been re-programmed, and you’d need to reverse that. https://www.bphobbies.com/pdf/bp/esc_2015/bp-hw30a-esc-2015.pdf

Will try reprogram it tomorrow. The strange thing is, when using px4 firmware the esc work. When flashing arducopter, esc stop working.

still no luck, reprogramming the esc’s. when moving throttle low it doesn’t respond. Should i buy some simonk?

The problem could be with your Transmitter/Receiver setup. What kind of TX/RX are you using? Do you know about configuring it?

That was what i was thinking, tried to google it but no luck with that. But honestly i have no idea where to look in this controller. So much settings :P. Tried something with the curve, but no luck there.



And this is my flightcontroller equipment:
Pixhawk 2.4.8

Dji F450 Clone


2212 1000kv


I don’t personally have experience with that TX/RX… but I’d recommend you learn how to configure it (may be a large task) and see if you can get your ESC’s working correctly when direct-connected to your RX before assuming your ESC’s have a flaw.

Maybe someone else can help?

Yes, i totally agree. Trying real hard to learn everything. :wink:

@hunt0r Do you have any idea why it works on this firmware? https://github.com/PX4/Firmware because if it is the esc or controller, then i still don’t understand why it works with the same setup and board and connections.

Here’s my best guess: Your Transmitter is sending some unexpected signal to the RX. The RX is happily passing that along to the PixHawk, to be interpreted by the firmware. (Ardupilot, or PX4)

Ardupilot may know what the unexpected signal is, have been designed to behave as you’re seeing, in order to alert you to the problem. OR, it may not know what the signal is, and be designed to behave this way to clue you in that something strange is happening. OR it may be just as confused as we are, and do something that (in retrospect) doesn’t make sense at all.

PX4 seems to handle the situation differently. It’s anyone’s guess (right now) whether that’s because it was programmed to handle whatever is going on, or whether it’s blissfully ignorant, and assuming things are fine.

That’s my best guess at why PX4 and Ardupilot are behaving differently. But I re-state: It’s ONLY a guess!

Thnx, I like you’re explanation very much. :’)

It is something strange, what is keeping me busy for some weeks now. You sound like you are an experienced guy. What would be your way to troubleshooting this? Because with just the RX and esc’s I can’t get it to work.
So either misconfigured RX or stupid esc’s it is. But I don’t know where to look anymore. Can you direct me in some point to look at in my controller? Trims? Or?

I ordered some new esc’s just in case it’s not the reciever.

The transmitter that I use (a Futaba one, I don’t necessarily recommend it) has a screen where I can view it’s transmission on every RC channel. If your TX has that, that’s where I’d start. If you observe that the TX is not sending signals as you’d expect when you move the sticks, then you know to dive into the TX configuration documentation.

If you have access to an oscilloscope, or something else that can read the pulse-width of the actual electrical signal out of your RX, that would give you the same info… but that’s harder, of course.

Calibration went without error in mission planner on Ubuntu.

Ik will hook it up on my Arduino or dad’s oscilloscope ;). Hate to do that, cause he want to give it to me and tells me I need it. But I have no room for it :’).

Thnx, I will keep you informed of my progress

Pls try to ARM the copter while connected to mission planner and look in the messages tab. Hope you have setup ppm or sbus in the Tx.