Pixhawk 2.4.8 (clone) and problems with copter firmware above 3.2.1

I have the problem with the same board px4(2.4.8);the onboard sensors aren’t working,when ever i try to calibrate the sensors wouldn’t give any response and the screen freeze for a long time when i cancel the calibration in Qgroundcontrol.
Does any one have a solution for this rather than buying new one.

I do have eight 2.4.8 : None of these have a sensor problem. (Using mission planner 1.3.66)

  • Are you using ChiBios?
  • What firmware and what version are you using?
  • On-board compass isn’t a good idea anyway but the altitude and attitude sensors should work.
  • How do you power your Pixhawk 2.4.8?

You may have fried your Pixhawk 2.4.8 with high voltage from a lipo…?

In any case a Pixhawk 2.4.6 with 2 Mb is a better choice today as the 1 Mb from Pixhawk 2.4.8 is near its maximum. So clones with 32 bit 2M flash memory STM32F427 Cortex M4 is a must.

Impossible to help you as you don’t give enough details.


I had the same problem with this clone Pixhawk. I notice you have the NuttX firmware.I did too.
I Installed the stable ChibiOS Firmware in Mission Planner.and it fixed the clone.

Hi all, I know this is an old topic but really hoping someone on here can give me some help. I’m having exact same issue as original post. No throttle response above 50% and when I switch to loiter drone stalls.

Worked fine up to very recently when I had a hefty crash which I was putting this issue down to but it’s clearly firmware related. Replaced 2.4.8 and GPS. Reflashed firmware on transmitter and pixhawk etc.

Ive tried flashing earlier versions of firmware onto the pixhawk after reading this post but it won’t allow me to go back to 3.3.x. Each time I try to upload any firmware past 3.6.11 or 12 it shows an error. Have tried all the 4.x firmwares and issue exists with each one. Calibrated everything numerous times.

I’m tearing my hair out these past weeks trying to resolve and have tried as far as I can see nearly everything but to no avail, when I take off with the drone it’s dangerous and uncontrollable.

ANY help will be massively appreciated, many thanks in advance.

Hi, can I download from somewhere the PCB and schematic files of Pixhawk 2.4.8 ?. One of my board is not showing any LED indication when power module is connected. I wanted to troubleshoot the board that is why, I need those.

No. You can find the Pixhawk 2.6 reference board schematics.

But it was a open source project means anyone can download and make his DIY !

The 2.4.8 is a bastard version of the reference board cooked up by some Chinese manufacturer. Find out who they are and plead with them to release the schematics. You won’t find them otherwise.

ok, thanks, I will rather trace the schematic my self as pleading before Chinese manufacturers is like pleading before the wall !

If it doesnt work with the latest stable Pixhawk1 firmware (or fmuv3) then it is faulty and it will be quicker/easier/cheaper to buy something that works

Can I get pcb and schematic of 2.4.6 which you said the reference

Google “Pixhawk Schematics” and follow the Github link.