Pixhawk 2.1 to Sabertooth 2x32 nothing

Flysky FS-IA6B to pixhawk 2.1 blackF Cube to Sabertooth 2x32

Hello all, wow am I having a huge learning curve.
I am very new and can’T wait to get up and running with my project.
First base is to enable my remote control to operate my rover platform via the pixhawk 2.1 black cube
Mission Planner 1.3.70 Build 1.3.7277 ArduRover V4.0.0(0e52bafa)
Sabertooth Dip settings are set to Radio control 1=off 2=on 3=on 4=on 5=on 6=on

I can see the one paddle operating within the mission planner software but can understand why the output to the sabertooth is not working
The only output setting that I can see working on the screen is radioPassthru soi set this on 1 and 3 output and still nothing to the both drive motors
I disconnect the PH 2.1 cube and made sure the radio to sabertooth was working and all good
I have learn that in order for the mission planner software to see the radio it must be on SBUS PPM
with all this learning its difficult to know what I have done wrong
Please see the following images to support my issue

Thankyou anyone that can help

IMG_8055 IMG_8056 IMG_8058 IMG_8059

1 Like

Which protocol do you want to use?

PPM: Connect it to channel 1
Sbus or ibus: connect it to the horizontal pins on the top.

I think ibus works best

Hello Vabe thankyou for your interest
Do you mean change from PPM TO PWM

No, if you set it up to use ppm, the signal comes out at the port of channel 1
but you should use iBus, that gives you more channels, and with a mod even telemetry

That’s how I have it connected:

1 Like

I can’t wait to try it out. I really appreciate your help.:+1:

Ok I moved the 3 pin to ibus but still no drive image

1 Like

The RC mapping is not default, is there a reason you changed it? Is your Transmitter set for AETR? What type of steering do you want to use? Paddle (tank) or conventional steer? Conventional steer is generally what you want.

One stick/paddle for skid steer image


OK, so the right stick on a Mode 2 radio, throttle up/down, steer right/left. Is PILOT_STEER_TYPE set to 0? I can’t help with the Sabertooth I use RC Truck brushed ESC’s for Rovers.

Ok if I see 4.8 volts going into power and I see 30millivolts coming out does this pose an issue

Correction I think I should be getting from 167 to 332 MV
Atleast that’s what I’m getting from RC to Sabertooth

What? 167 to 332 mV from where?

To further understand why I’m not get any functionality from this black cube I decided to measure some outputs
If I connect the receiver to the Sabertooth 2x32 without the cube
I get a mV range of 167mV to 332mV output from receiver.
Then when connecting the Pixhawk cube between the RC receiver and the Sabertooth I get 32mV output from the Pixhawk Cube.
Has anyone taken the same measurements.
Input voltage to the receiver and cube is 5 volts

The output from the receiver is PPM/Sbus. Measuring it with a volt meter is meaningless.

I can see your trying to help, I will go through each step and try to work out how to solve this issue.

Trying. Some of these questions I asked and some other comments:
Is your Transmitter setup for AETR order?
Is it setup for Mode 2?
Are you trying to control the rover with the right stick, up/down for throttle, right/left for steer?
Do the channells move with the sticks in Mission Planner Radio calibration screen?
What is the PILOT_STEER parameter set to?
I believe you want the Sabertooth dip switches like this. 1-Off, 2-On, 3-Off, 4-Off, 5,On, 6-On Which is:

Servo Output 1 to left motor ESC input
Servo Output 3 to right motor ESC input

@Rooster This stuff is very confusing, there’s a lot going on. I made a post about this exact situation a few months back (so I wouldn’t forget). Maybe it can help you:

Like @dkemxr said, try plugging two channels of the receiver into the S1 and S2 terminals on the Sabertooth. If your Sabertooth is working, moving the sticks in some direction should result in some detectable change in rotation on your motors.

Be careful about how you set the DIP switches on the Sabertooth. For skid steer I think you want the Pixhawk to mix the throttle and steering channels. The Sabertooth can mix them if you set one of the DIP switches but then it gets double mixed and things get really funky.

I hope this helps.


That’s why you want it set for Independent. Ardurover is not suppling throttle on one chan and steering on the other. It’s output is 2 chan mixed. But there are several things you can get wrong. The most common is confusing inputs and outputs.


Morning Drew
I can report some degree of success as I can now move the wheels
It requires more calibration to achieve the correct movement
I can’t tell you how much your article was so beneficial.
My initial concerns were that maybe I had blown up the cube before I started.
Where I have failed is to understand what change made a difference.
Once I get both wheels to move correctly I will make sure I record all calibrations.
And report back to you.
As a new person to this technology it’s great to know you and Dave are here to help.
To both of you keep in mind your helpfulness is 100% appreciated

1 Like

Hi Dave,
Really appreciate your help I’m now getting movement