Servers by jDrones

Pixhawk 2.1 no longer working with DJI 620S ESC


(Michael Letterio) #1

After upgrading to version 3.4.6, the Pixhawk controller seems to no longer communicate with DJI 620S esc. When I connect the ESCs to DJI firmware update software and power on the flight controller, the DJI ESC update tool indicates that there are no signals being sent to the ESC. Is the flight controller output dead? Or is this version of the Arducopter incompatible with this ESC? The safety switch seems to respond to input by changing from flashing red to solid red. When I upload the Arduplane firmware, it arms one single motor. However when I reinstall Arducopter firmware, not one motor arms.


(Luís Vale Gonçalves) #2

I too have a E800 propulsion kit without any issues while connected to a PixHawk, either running 3.4.6 and lately 3.5RC9.

Please set the MOT_PWM_MIN and MOT_PWM_MAX to 1120 and 1920us


(Michael Letterio) #3

Thanks for the response! Unfortunately that still has not solved the problem. Do you have a param list available?

What is RC_SPEED set to? 400Hz?


(Masters Will) #4

Any update here? Have you tried any firmware versions prior to 3.4.6 or a different pixhawk board (is your problem specific to your hardware combination or to the upgraded firmware)?

I’m working on a pixhawk build w/ E800 and haven’t powered everything yet… I had issues with the 620s esc on an earlier build and hoped that was all behind me.


(Luís Vale Gonçalves) #5

Like this


(Michael Letterio) #6

When pressing the safety switch, the ESCs do not respond. The ESC indicator LEDs continue to flash yellow and the motors create a repeating tone. I am unable to get to the point where the DJI start-up tone is made when the safety switch is pressed. The aircraft has flown before, I’m trying to figure out what has changed after the firmware update.


(Gregoire Linard) #8

@Michael_Letterio did you solve your problem ?

@luisvale On your setup, did you change the wires between ESC and motors ? It seems the ESC are “too smart” and can detect which motor is plugged… but I figured that when extending the wires, the measure (resistance ?) isn’t the same and ESC won’t detect the motor hence not arming.


(Michael Letterio) #9

@Kiwa21 Still have not solved the problem. I have tested the motors and ESCs using a Graupner RX, they work fine and respond to throttle input. I’m not sure why the pixhawk is still failing to send out a signal that the ESC understands.


(Jagger) #10

Use the Mission Planner motor test in optional hardware.That will give you a bit more info.


(Gregoire Linard) #11

From the test I ran, it appears to be resistance / inductance issues between output of ESC and input of E800 motors. 620S is a “smart” ESC that autodetect the motor it is connected to.
I had 0 trouble when connecting with “default” cable length, but when you try to extend the cables problems arise ! DJI seems to confirm this issue as well.


(Michael Letterio) #12

@Jagger I’m using APM Planner, is there a way to test motors using that software?


(Jagger) #13

I haven’t used it for years but apparently that’s a no.From the forum…

"billb Bill Bonney Developer
May '16

Not directly using only MAVLink. I did start to add it, but never completed it."

Sorry.I use the Mission Planner test all the time and find it mighty useful.


(Michael Letterio) #14

@Jagger Is Mission Planner available for macOS?


(dany) #15

so ,have you find any solution …


(dany) #16

it works all well on first arming , but aftter switching batteries ,or aftter powering down it begin to play red-yellow and it isnt able to arm the esc/motors …
then if you just put it 20-30 min whit no power on it is working ok again …
realy dont have any idea more to solve this …


(Michael Letterio) #18

@drvic1 I’m not sure if your problem is related but it very well could be. When you refer to “arm”, when its armed do the motors spin? Or when its armed do the motors stop buzzing and yellow flashing turn to red and green on the respective lights?


(Paul Atherton) #19

Danijel, Yoiu should have really created a new topic for your issue rather than jumping on an unrelated existing topic, but I think I can possibly help you. Can I make the assumption that you have an original Pixhawk PX4 v1 - maybe hardware spec 2.4.5? If the answer is yes, then there is a power supply issue on that hardware spec which affects one of the IMUs. I see your exact issue on my oldest hexacopter - and I have a work-around. The solution is that after first flight, once your battery is disconnected and removed, short out the power connector on your quad, this will discharge the capacitor of the supply to that IMU - hold that short for say 30 seconds, then remove it, and connect up your fresh battery, and hopefully the Pixhawk should work as well as it did on the first flight. It works for me every time. My newer v2.4.6 spec Pixhawk does not have this issue.


(Jagger) #20

Michael.

Again from the wiki

"Mission Planner

Full featured and widely used GCS.

Platform: Windows, Mac OS X (Using Mono)"

I’ve no idea what Mono means but it may mean something to you.


(dany) #21

thank You for advice , I have allready tryed to short out power aftter taking batteries off, but no efect …
so I have taken maytech 60A and put them on , now building on new fw, 3.5rc11 …
Hope it will do better than last … 3.4.6.
Thanks once again


(Eric Wikramanayake) #22

Also had this problem.
Disable the safety switch when using DJI ESC’s by setting BRD_SAFETYENABLE parameter to 0.