Pixhawk 2.1 gyro and compass problem

I am one of the first “lucky” owners of Pixhawk 2.1.
Unfortunately I didn’t manage to make it work properly so far.

First of all I had difficulties to complete the Accel calibration. Most of the times the calibration process just stuck, specially if I am doing calibration through the wizard. Other times just says “calibration failed”. The few times that I was able to complete the calibration, I was getting the message “bad gyro health”.

Also I have problem with the 3rd compass. Every time that I am doing calibration is failing.

The only way that managed to make it work without error messages, is when I am deactivating the 1st gyro from (INS_USE) and the 3rd compass.

Although, I can see the values gy, gx, gz, changing when I move the board. The compass readings are changing as well, but the numbers are significantly bigger compared to the other 2 compasses.

I don’t know if the board is defective or is firmware issues.

I tried to fix the problem by formatting the sd card, reinstall the firmware many times, reset to default settings, change PC, change space, change USB cable. The result is the same.

All the test that I have done, are with the board connected with USB and without any other peripherals connected.

I’ve already tried with the all latest stable versions of copter V3.4.2 and plane V3.7.1. The mission planner version that I am using is 1.3.41.

Any idea what might be wrong or how I can track the problem?

You use MP or QGc.
I spend the same, until I perform the compass calibration on-board with mp.
With this I solve everything.

Extracts from Facebook group:

For those of you having issues with your Pixhawk 2, I’ve found some interesting facts. I had the same long delay issues going through the cal procedures. I tried 3 separate pcs in my house running the current version of mission planner. If by some chance i made ti through accel cal it would never make it through compass cal. I took it to my son’s house and it passed both cals easily. I believe the Pixhawk 2 may be sensitive to EMI. Try moving as faraway from electrical components as possible with the exception of your mission planner pc.

Based on the developer: by definition it is designed to be extremely sensitive to the magnetic field in order to measure it.

Did you get past these issues?
I constantly get “bad gyro health” and “compass not calibrated”

I’ve been told that Bad Gyro Health error can be caused by temperature change (IMU heater)
Try rebooting it after letting it warm up.

Compass error: maybe you haven’t calibrated all 3 compasses?

I usually reboot it a dozen times. It’s definitely warmed up. The default of 60 degrees seems high to me, but I assume that’s what it should be.

Depending on the day it might say I have 2 compasses or 3. And I still don’t know if it has 2 or 3… the specs at proficnc say it has 2, other places say it has three… anyway, I deselected the third one. I don’t seem to get the compass error as much any more after that…
But bad gyro health pops up at random times… I don’t know if I should just ignore it or what.

And I’ve tested this with nothing but a USB cable plugged into the board.

Is it at all possible to use external compasses with the Pixhawk2?

Same to me! No idea how to fix it :pensive:

I am having the same problem with compass calibration.
Tested on 2 different Pixhawk2 FCs, with the same result.
Calibration is always successful, but after power cycle, the FC says that the compass is not calibrated.
This can be repeated as many times as possible, always with the same result, pre-check fails.

The only solution is to disable compass2 or compass3, so leave only 2 active compasses, one external
and one internal.
After recalibration with only 2 compasses enabled, the pre-check after the power cycle is successful in ~50%.

This is very, very bad. Even in one case it happened that after the pre-check was finally okay, after takeoff
in loiter mode, the copter has just flown in one direction, and none of the RC controls was active, except throttle.
Having a ~8kg quad, this is really frightening.

I suspect rather the firmware to be not prepared for the Pixhawk2 correctly, than the hardware itself.
Note that even the initial board orientation in MP is changed by 180 degrees in pitch direction. Why??

Overall, the FC is unreliable and I had to go back to the old Pixhawk, that works okay.

@Proficnc: please solve these issues as soon as possible, otherwise I am afraid nobody is willing to use
the new FC.

1 Like

Hi All
Please Try the beta firmware on copter, 3.5rc1. Doing the onboard calibration.

Ensure you are using the Beta mission planner.

Also, you can adjust the onboard compass calibration to control how fussy it is.

Regarding the Gyro message. Please let me know if it is still there with the latest mission planner and 3.5rc1


It is the same problem… 3.5 rc1 and mission planner update do not fix anything. (That’s what I was running)
Instead of the Service Bulletin thread, I’ll post my log file, etc here.

1.BIN (1.6 MB)

@icahone I am fighting the same issue at the moment with the PH2.1

It is fine tuned in Stab and Alt hold, but switch to loiter and it takes off in random directions.

8kg Octo
FW 3.5rc1
Septentrio GPS

Still trying to find the issue.

Rather than disabling, try setting compass 2 as external, and set the orientation to yaw 180… Reboot and calibrate…
This is what I got, note that I had two externals connected at the time.

if you have 2 external units fitted, then compass 2 is external.

“I’m trying to give ample opportunity for a response… before I “let it all out.” :slight_smile:

Hi John
First thing… looking at posts, I respond to posts on the topic. your issue needs its own post. your log is only part of the story, please clearly show the backstory. what happened on this flight? what were the conditions? what is the frame, what is fitted? how did you tune it? did you tune it?

your post has no relationship to the SB post. that’s clear…

my only comment… tuning doesn’t look great to me… or the copter may not be configured correctly for the build?

I cannot see any issues that make me suspicious on your hardware.

all IMU’s agree, all Compasses agree, both GPS’s agree, both baro’s agree… your vibrations look good.

however, all your compasses are set to internal… why are you not using external compasses? what GPS’s are you using?

I have asked others on the dev team to assist in finding your issue here.

without logs, we cannot do anything. please send logs. you must set logging while disarmed.

are you using a ProfiCNC/ Hex external compass?

Philip,two external units possible or not?

yes, as there are two external I2C busses.

Hello again,i do not understand this
"Philip,two external units possible or not?
yes, as there are two external I2C busses…"??
Till now it was not possible to have 2 external magnetometers…where would i connect it?in parallel with other i2C devices on i2C port??

…and yes after initial calibration i also get random BAD GYRO HEALTH…i will try to do calibrations again
…and this is 15kg X8

I just hope this is not same problem we had with pixhawk long time ago…

The first mag connects on the gps1 plug, the second on either the GPS 2 connector, or the additional I2C connection.

Regarding Gyro error. Please submit a log of the issue. This is a long standing issue, and the Devs need logs to get to the bottom of it. Please start a new topic for it when you do.


1 Like